Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

For years I have the following problem that I'd like to solve finally.

I have my own server with an email account, e.g. me@work.com. Then I have another identity (email address with another domain, but belonging to my server), let's say me2@home.org

The Mozilla wiki Multiple identities per e-mail account says:

When you reply to a message, Thunderbird uses the identity that matches the address the message was originally sent to, if it can find a match in the account you are working in.

Well, when I reply to an email that was sent to me2@home.org Thunderbird always uses me@work.com as the sender. Always.

I tried a lot but could not find a solution until now, how frustrating!

share|improve this question
1  
Doesn't the Flexible Identity extension mentioned on the Mozilla wiki page help? – M K Sep 17 '13 at 11:51
    
Did you setup the multiple identities under the same account or do you have multiple mail-accounts with its own identity? – Rik Sep 17 '13 at 12:22
    
That's weird. Long ago it worked here. Now i tried it and it also failed to select the correct identity. Do you use IMAP or POP. (I now use IMAP.) If i copy a couple of mails to the "Local Folders" and reply from there it does work. – Rik Sep 17 '13 at 13:13
    
thx 4 ur feedback. / Flexible Identity plugin says it is analysing the recipient not the receiver email. / I have one mail account with 2 identities. / I am using POP on port 995 (SSL/TLS). / I am surprised, within the Local Folder it works, problem is I don't use the Local Folder. So maybe we have a bug here? – Kai Noack Sep 17 '13 at 13:20
    
I don't know what changed (maybe the new Thunderbird 24.0) but for me it is working again (also with my IMAP-account). When replying a mail send to our info@ address i get the correct identity in the From field. – Rik Oct 10 '13 at 12:15

The add-on folder-account (suggested by Matheretter) helped for me too.

Enabling and disabling this add-on I figured out that the problem of the wrong identity when replying occurs when:

  • the message is an automatically forwarded (aliased) message, so that my e-mail address is not in To or CC, but in Envelope-To, for example:

    default account: me1@test.com
    external mail address that forwards (with Envelope-To) to me1@test.com: external@mail.com
    other account in TB (but not the default): me2@test.com

If a message is sent to external@mail.com it is forwarded to me1@test.com and TB by message filter puts it into an inbox-folder for me1@test.com.

Without the folder-account add-on OR with the add-on, but with "use Default" in the folder properties "from-account"-setting:

  • when replying the message it uses me2@test.com as identity and strangely not the identity related to the default account (me1@test.com).

With the folder-account add-on enabled AND in the folder properties the "from-account" setting set to me1@test.com:

  • when replying the message it does use the desired identity me1@test.com
share|improve this answer

After years I finally found a solution! Here you go:

  1. Install https://addons.mozilla.org/en-US/thunderbird/addon/folder-account/
  2. Create folders for each identity
  3. Create filters to move incoming emails to according folders
  4. Click on properties of each folder, you will see some additional options (due to the addon installed)
  5. There you specify the From Account: for each folder.

One longtime headache and time waster removed from my life ;)

share|improve this answer

There is possibility, that te @work address is used, because there is no sending account @home (but there is inbox for @home).

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .