Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to mount a laptop hard drive during a Debian install for the purpose of backing it up to a USB external drive. I can't use the external drive from the existing OS on the laptop because it is so old it cannot read the external drive. When I boot the machine from the Debian CD I interrupt the install process at the "provide host name" screen, then select the run shell option from the menu. The installer announces I will be using the ash shell from a ramdisk and that the local hard drive partitions have been mounted to /target. fdisk confirms both the presence of the hard drive partitions (sda1-sda7) and the external drive partition.

Unfortunately I can neither find /target nor can I mount the drives manually. There is no /target directory on the ram disk.

If I try to mount any of the partitions using a command such as:

mkdir /mnt/sda3
mount /dev/sda3 /mnt/sda3

I get the error "invalid argument" and the dmesg is a bread (block read) error on sda3. I have also tried different -t (type) options with the mount, such as ext3, fat32 or vfat (for the FAT partitions), nothing works, same error.

If this error is because the partition type must be specified how can I find out the authoritative label to be used with the -t option? fdisk -l does not provide this label.

MORE INFO

The fstab is kind of like this:

none   /devpts   devpts   default
none   /run      tmpfs    default
none   /proc     proc     auto
none   /sys      sysfs    default

Executing df gives the following result:

none       /run
tmpfs      /dev
/dev/sr0   /cdrom
share|improve this question
    
please show us the contents of your fstab –  Lorenzo Von Matterhorn Sep 17 '13 at 15:56
    
I don't have the fstab in front of me but as I recall it had 3 entries, all of the "sysfs" variety. There was no reference to sda in it. I can post it when I get home. –  Tyler Durden Sep 17 '13 at 17:23
    
Is there a good reason to use an installer shell and not a Live distro such as Knoppix? –  Ярослав Рахматуллин Sep 18 '13 at 7:06
    
I could use Knoppix, its just that I had Debian/BusyBox already running since I was doing an install so I thought there should be a way to do it using BusyBox. –  Tyler Durden Sep 18 '13 at 15:03
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.