Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to install Windows 8.1 RTM (from MSDN) ontop of a Windows 8 installation.

When trying to run the upgrade from Windows 8 running Setup.exe either from ISO or from a USB stick I get:

"You cannot install Windows on a USB flash drive from Setup"

Windows 8 is installed on C: and there are no connected USB drives when installing from ISO, or the USB key when trying to install from that.

I've also tried installing off the bootable USB key by booting from there, which gets me to the point of selecting a drive to install on at which point it tells me that there's no valid partition.

Other info: I deleted the Windows recovery partition some time ago and when running the full setup from the USB key the 8.1 installer created a new empty one (even before it asked permission to install anything). So now I have an extra partition that's showing up as an extra drive letter and I can't remove it even using DISKPART.

Installed 8.1 on another machine today and that worked without issues, so it seems clear that this is related to the machine config somehow.

Any ideas what the installer is getting hung up on here?

share|improve this question
1  
Windows 8.1 isn't publicly available yet - or am I missing something? You might want to specifically mention if this is 8.1 Preview. –  allquixotic Sep 17 '13 at 21:20
1  
@allquixotic Actually it is. MSDN and Technet is close enough. The problem the user has is they need to use the Windows Store to do what they want which isn't available –  Ramhound Sep 17 '13 at 21:21
1  
You can get RTM release of 8.1 from MSDN now. –  Rick Strahl Sep 17 '13 at 21:23
1  
The lack of the recovery partition is likely the cause of this issue I would wait until the Windows Store method can be used –  Ramhound Sep 17 '13 at 21:25
    
Yeah I think that's probably it. Is it possible to recreate the recovery partition - the partition and size is actually there now just the data's not on it... –  Rick Strahl Sep 17 '13 at 21:31

1 Answer 1

up vote 1 down vote accepted

Check this thread: http://answers.microsoft.com/en-us/windows/forum/windows8_1_pr-windows_install/you-cant-install-windows-on-a-usb-flash-drive-from/be16d060-7b7f-48fa-b56e-4faf7cd28a6d?msgId=5cbe976a-de77-45a0-93c3-82aa860dcc38

Especially part about:

change the value of PortableOperatingSystem in regedit HK_Local_Machine/System/CurrentControlSet/Control/ from 1 to 0

It worked for me.

share|improve this answer
    
Yup that worked for me too! Anybody know what that flag means or more importantly how it got set in the first place? –  Rick Strahl Oct 21 '13 at 22:45
    
I had this strange behavior only on computers with windows installed from scratch (not happening on windows upgraded from 7). I had also noticed on one of them that this key had gone after some auto updates, maybe Microsoft has fixed it. –  user258966 Oct 23 '13 at 16:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.