Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to run Blender under Linux, but I'm unable to do that, whenever I try I get some errors. I'm using Kubuntu 12.04 with KDE 4.11.1.

This is my video card:

~$ lspci | grep VGA
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RV610/M74 [Mobility Radeon HD 2400 XT]

I used to have installed the fglrx proprietary Catalyst drivers, but lately they gave me some system-wide problems and I had to revert to the open source Mesa drivers (I don't think that these details are important, but just in case, the whole story is here).
Whit the fglrx drivers Blender was running fine, but now, whenever I try to start it, I get this error message (some parts are in italian, but I think that they are easily understandable):

~$ blender
connect failed: No such file or directory
Writing: /tmp/blender.crash.txt
Errore di segmentazione (core dump creato)

The content of /tmp/blender.crash.txt is as follows:

# Blender 2.68 (sub 5), Revision: 60150

# backtrace
/usr/lib/blender/blender() [0x877a41f]
[0xb7756400]
/usr/lib/i386-linux-gnu/libLLVM-3.0.so.1(_ZN4llvm3ARM8SPRClassC1Ev+0x15) [0xa8f4a9d5]
/usr/lib/i386-linux-gnu/libLLVM-3.0.so.1(+0x25ca48) [0xa8eefa48]
/lib/ld-linux.so.2(+0xeeab) [0xb7765eab]
/lib/ld-linux.so.2(+0xef94) [0xb7765f94]
/lib/ld-linux.so.2(+0x12fa6) [0xb7769fa6]
/lib/ld-linux.so.2(+0xeccf) [0xb7765ccf]
/lib/ld-linux.so.2(+0x127f4) [0xb77697f4]
/lib/i386-linux-gnu/libdl.so.2(+0xbe9) [0xb4ff9be9]
/lib/ld-linux.so.2(+0xeccf) [0xb7765ccf]
/lib/i386-linux-gnu/libdl.so.2(+0x133a) [0xb4ffa33a]
/lib/i386-linux-gnu/libdl.so.2(dlopen+0x47) [0xb4ff9c97]
/usr/lib/i386-linux-gnu/mesa/libGL.so.1(+0x3cbf0) [0xb7717bf0]
/usr/lib/i386-linux-gnu/mesa/libGL.so.1(+0x4079d) [0xb771b79d]
/usr/lib/i386-linux-gnu/mesa/libGL.so.1(+0x1a3aa) [0xb76f53aa]
/usr/lib/i386-linux-gnu/mesa/libGL.so.1(glXQueryVersion+0x2e) [0xb76f0cee]
/usr/lib/blender/blender(_ZN15GHOST_WindowX11C1EP15GHOST_SystemX11P9_XDisplayRK10STR_Stringiijj18GHOST_TWindowStatei25GHOST_TDrawingContextTypebbt+0x11c) [0x8f54aec]
/usr/lib/blender/blender(_ZN15GHOST_SystemX1112createWindowERK10STR_Stringiijj18GHOST_TWindowState25GHOST_TDrawingContextTypebbti+0xd7) [0x8f4f4a7]
/usr/lib/blender/blender(GHOST_CreateWindow+0xb6) [0x8f4cf86]
/usr/lib/blender/blender(wm_window_add_ghostwindows+0x205) [0x8799be5]
/usr/lib/blender/blender(WM_check+0x50) [0x877b670]
/usr/lib/blender/blender(wm_homefile_read+0x111) [0x87859f1]
/usr/lib/blender/blender(WM_init+0xd2) [0x8787872]
/usr/lib/blender/blender(main+0xe6e) [0x873848e]
/lib/i386-linux-gnu/libc.so.6(__libc_start_main+0xf3) [0xb4e694d3]
/usr/lib/blender/blender() [0x8778a99]

The only thing that I can guess from this report is that the mesa drivers are somewhat involved, as I already suspected, but I don't have a clue on what I need to do to try to solve the issue.

share|improve this question
    
Use the Ubuntu package and not the installer from the blender site. –  Ярослав Рахматуллин Sep 18 '13 at 6:50
    
I haven't used the package from the blender site, it's from this repo launchpad.net/~irie/+archive/blender and worked fine until I had to disable fglrx. –  Sekhemty Sep 18 '13 at 10:48

1 Answer 1

If you are using debian-based distro, try to install firmware-linux-nonfree package to make opensource drivers work properly with direct rendering.

Ps. don't forget to reboot system after installing firmware package.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.