Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I run cmd.exe from the Start button, then run "whoami /groups" in order to view the access token, I see that the Administrators group is not in my access token. That's good - I want to not have Administrators in my access token. The problem is, when I run another program from the Start button - \cygwin\bin\mintty (which gives me an interactive shell), then run "whoami /groups" from that shell, I see that I am in Administrators:

BUILTIN\Administrators Alias S-1-5-32-544 Mandatory group, Enabled by default, Enabled group

I do not want to be in the Administrators group when I run mintty.exe. What is causing Administrators to become part of my access token, when I run \cygwin\bin\mintty.exe (but not when I run cmd.exe)? How do I stop that from happening?

share|improve this question
    
I discovered a Cygwin utility - cygdrop (part of the cygutils-extra package) - whose purpose is to drop specified privileges from the access token in a spawned process. By default, it drops all Administrator privileges. Unfortunately, I found that when I run "cygdrop /cygdrive/c/Windows/System32/whoami.exe /groups", I see that the Administrators group is still in the access token. Adding in the -v flag to cygdrop, I see that it does the following: $ cygdrop -v echo -n d S-1-5-32-544 [enabled] [default] gid=0(root) d SeIncreaseQuotaPrivilege ... So it's trying to drop Admin, but fails. –  cmessenger Sep 18 '13 at 14:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.