Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

After updating to Kubuntu 13.10 beta (kernel version is 3.11.0-7-generic) my nfs share stopped auto-mounting during boot.

Here is my fstab:

dimanne@Impedance:~$ cat /etc/fstab
# <file system>                           <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda1 during installation
UUID=328a9124-e5ff-4c13-a7e2-559ee6a20292 /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
UUID=b3a4a4a4-c563-45c1-9d6b-602b07d66c70 none            swap    sw              0       0
# was on /dev/sdb1
UUID=9383ee42-aea8-4098-9533-08d1b9b04e59 /mnt/backup    ext4   defaults        0       2
# was on /dev/sdc1
UUID=4ad4e84a-1e0e-4cb6-a63a-753d3ffc9ff2 /mnt/freedata ext4    defaults        0       2

server:/mnt/media                       /mnt/media      nfs4    defaults

Also I noticed suspicious messages in dmesg:

dimanne@Impedance:~$ dmesg | grep killed
[   23.436063] init: idmapd-mounting (/mnt/media) main process (455) killed by TERM signal
[   26.828198] init: failsafe main process (1119) killed by TERM signal
[   28.352642] init: kdm main process (1757) killed by TERM signal

However if I mount nfs share manually (sudo mount -vvv server:/mnt/media /mnt/media) all works perfectly, but at this time I get these messages in dmesg

[  458.804009] NFS: Registering the id_resolver key type
[  458.804024] Key type id_resolver registered
[  458.804026] Key type id_legacy registered
[  473.827828] RPC: AUTH_GSS upcall timed out.
[  473.827828] Please check user daemon is running.

What is the problem, how can I fix it?

share|improve this question
add comment

2 Answers 2

check your fstab file in the startup. Edit the fstab file in read write mode and then reboot the machine.

share|improve this answer
    
What edits should be made to the fstab file? –  Excellll Sep 18 '13 at 17:39
    
If the machine is in a network, check the fstab file in another machine. Make those changes in the affected machine and try remounting. –  Ramesh Sep 18 '13 at 18:32
add comment

Sounds to me that the mountall is happening before the NFS package has been initialized fully of needs more time to initialize fully.

Fixing it might involve moving the NFS initialization earlier in the reboot cycle.

I'd also add 'bg' for the NFS options. If the first mount attempt fails, it will put the mount in background to retry the request LOTS of times.

share|improve this answer
    
Unfortunately bg option did not help... –  Void Sep 18 '13 at 18:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.