Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Windows 7 x64

HDD 1 SATA multiple partition including windows in C:\

HDD 2 IDE (I added this drive later to the system) partitions-1 primary partition-2 logical

windows page file: system managed

since ide appears as Disk 0 in diskmgmt and first partition on this drive is also primary in addition to SATA c:\ primary I think IDE takes priority and my system creates a pagefile.sys on this IDE drive partition-1

When I remove my HDD 2, pagefile is created on HDD 1 SATA as it should be.

I wish to keep page file as system managed and stop the IDE drive creating a pagefile.sys on it. Because this IDE is less capacity drive and pagefile.sys taking lot of space unwantedly on it.

is there a way. should I make IDE HDD all partitions logical or any other way possible?

share|improve this question
add comment

1 Answer

If you want to let the system to fully manage the page file(s), then you have to let it do what it wants.

Otherwise:

Uncheck "Automatically manage paging file size for all drives" and instead pick (just) the drive you want a system managed page file on, and set it to "System managed size".

Then select the drive(s) you don't want a page file on and set it to "No paging file".

Windows 7 Virtual Memory dialog

share|improve this answer
    
Thanks for reply, I changed the partition type on HDD2 partition-1 from 'primary' to logical from direct boot utility. but with system managed, same partition gets pagefile.sys . reason is that my RAM is 6GB and this HDD2 partition is the only one having more than 6GB space free, all partitions free space on HDD 1 have are far less than 6GB available. anyways I think that's the way to go you told. either system managed or set manually and exclude he required partition. –  sunnyimran Sep 21 '13 at 15:20
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.