Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using Firefox & add-in Vimperator and want to use Sublime to edit textareas.

Currently when I focus textarea and press CTRL+i I get "Command not found: gvim". I already have Sublime installed and would love to use it if possible for editing text in textareas. Any idea how I can do that?

share|improve this question
    
When you focus using what program? Using what operating system (both sublime and vim are cross platform)? –  terdon Sep 18 '13 at 20:29
    
You may want to consider using wasavi instead, though it might not be as feature-rich as you want. –  K Robinson Sep 20 '13 at 15:04
add comment

1 Answer

OK, I'm typing this from within the Sublime Text 2 editor... it proved to be harder than I expected.

You need to go to: c:\Users\$USERNAME$_vimperatorrc and enter this line:

set editor='d:\\Portable\\Sublime\ Text\ 2.0.2\ x64\\sublime_text.exe -f'

Make sure to escape both \ and SPACE like you can see from example. This thread helped: Vimperator. Setting an external editor in Windows XP

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.