Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am extremely new to Linux / Unix as a whole, so I apologize in advance for any ignorance that may be perceived by this question.

I am trying to execute a script to set up a control panel from the front-end of a server so I can finish setting it up. (For all of the details, I am trying to install the Minecraft control panel "Multicraft" onto my Webmin server).

However, I have ran into the challenge where I know the file's location:

/~/multicraft/panel/install.php

But I just do not know how to execute this script from the front end, like from a browser. When I navigate to the file's location (https://xxx.xxx.xxx:10000/multicraft/panel/install.php), it just says in big, bold letters: Error - File not found.

To elaborate: I have tried accessing this page by using http:// but for nothing. When I use http://, it just loads a blank page with nothing on it.

I have also tried excluding the port (:10000) from the link, but when I do that, it says that the page could not be deleted.

I have been following the tutorial for setting up the Multicraft control panel as closely as possible for the Linux 64-bit instructions. I have executed all of the commands that they provided as the root user in the ~/ directory.

The commands I have done so far are as follows:

# wget http://www.multicraft.org/download?arch=linux64 -O multicraft.tar.gz 
# tar xvzf multicraft.tar.gz
# cd multicraft
# ./setup.sh

This is all I have done so far.

What can I do to make this file executable from the likes of a web browser? I am totally confused and out of league with what I'm doing right now. Thanks in advance!

share|improve this question
    
If it's a one time script ask you service provider to run it for you –  50-3 Sep 18 '13 at 23:13
    
@terdon: Yes, the script must be executed from a browser for setup, unfortunately. I am not sure – if by command line you mean SSH access, I do have that. –  jflory7 Sep 18 '13 at 23:54
    
@50-3 I will look into that possibility. –  jflory7 Sep 18 '13 at 23:55
    
Why would it need to be executed from a browser? That is very strange. If you have ssh access, just do ssh you@server php ~/multicraft/panel/install.php. –  terdon Sep 18 '13 at 23:59
    
@jflory7 by the by this is probably off topic if it's a 3rd party host, Personally having setup a bunch of wordpress sites I just find it easier to get my provider - also more secure :) –  50-3 Sep 19 '13 at 0:00
show 8 more comments

1 Answer 1

up vote 0 down vote accepted

The issue I was having was that I had not installed the apache2 web server to my dedicated machine, and the script that Multicraft was wanting me to execute expected the script to be located in /var/www/html/multicraft/, which at the time, I was not aware of.

To fix my problem, I first installed apache2 by doing yum install httpd, and then I typed service httpd restart. After this, my web server was online, and I reexecuted the setup.sh file.

Upon doing this, Multicraft placed the front-end files in the web directory for apache2, and I was successfully able to finish the installation.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.