Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Now I have Win7 on my laptop, and I want to install Linux. I downloaded the latest Ubuntu 13.04 32-bit (and also Mint 15 32-bit), and installed it on my flash drive using the Universal USB Installer – Easy as 1 2 3 (also tried UNetbootin). Then I reboot from the flash drive I simply got a blank screen with a blinking cursor. Nothing happens at all. No harddrive activity.

Then I used LinuxLive USB Creator to install it with a Virtual Box on the flash drive, and tried to boot directly within Virtual Box, got the same blank screen. What is going on? This is not the first time I install Linux but I really got no clue.

My latop is a Sony VAIO with Pentium Dual-Core T2330 CPU.


Update:

Now I installed virtualbox and I'm able to boot from the ISO image, which means both my computer and the ISO image should be fine. However I'm still not able to boot from the USB to really install Linux on my computer. This is so frustrating, I don't want to be stuck with Windows!

share|improve this question
    
Assuming your install media is valid, correctly chosen and not corrupted (and honestly this is the most likely cause), what I can think of is that USB 3 drivers are often not working when the computer first boots. Therefore plugging a keyboard into an USB 3 port won't allow you to access the boot menu, and I presume plugging an USB key into it won't allow you to properly boot from it either. –  Ariane Sep 19 '13 at 2:42
    
Yes, media should be fine (I downloaded 3 distros), and the USB drive should be fine too (read/write without problem). –  LWZ Sep 19 '13 at 3:32
    
My guess is that the bootloader is incorrectly installed on the flash drive. I've also had issues booting from any USB mass-storage device on particular systems, though - can you test with a different PC to see if it boots from that device? –  user55325 Sep 19 '13 at 4:42
    
@user55325 I tried another computer, it's the same thing. –  LWZ Sep 19 '13 at 20:36
    
Well, if a USB stick boots on one machine (be it virtual or real) but not on another, it could be a BIOS incompatibility. Not all BIOSes are able to boot from all USB sticks (even a VirtualBox machine has a BIOS). How big is your stick ? I've heard about a 4GB limit in some BIOSes. –  Markus N. Sep 19 '13 at 22:23

3 Answers 3

Run VirtualBox, click Settings, select System in the left pane then go in Processor tab.

Check Enable PAE/NX.

enter image description here

Reference


What is PAE?

The Enable PAE/NX setting determines whether the PAE and NX capabilities of the host CPU will be exposed to the virtual machine. PAE stands for Physical Address Extension. Normally, if enabled and supported by the operating system, then even a 32-bit x86 CPU can access more than 4 GB of RAM.

This is made possible by adding another 4 bits to memory addresses, so that with 36 bits, up to 64 GB can be addressed. Some operating systems (such as Ubuntu Server) require PAE support from the CPU and cannot be run in a virtual machine without it. Manual

share|improve this answer
    
Adding explanations as to how and why this solution works would be nice. –  Ariane Sep 19 '13 at 21:22
    
ok, now I am able to boot into Mint in the virtualbox. However, I still can't boot from USB to really install it on my computer. –  LWZ Sep 19 '13 at 21:43
    
@LWZ check enable the usb device in menu: Devices - Usb Devices, and restart the virtual machine. –  QMechanic73 Sep 19 '13 at 21:47
    
@Джеймс_C웃, I want to install Linux on my real machine, not virtual machine. I'm trying VirtualBox just for testing purpose, and now it works. So I want to move on and install it alongside Windows. –  LWZ Sep 19 '13 at 21:53

Depending on the distro you can do the proper setup from within the VM. If you can enable usb passthrough or the equivalent for the usb stick, you can use the linux vm to dd the iso onto the usb stick, which works on a fair amount of distros.

share|improve this answer

Try Using POWER ISO->"Create bootable USB drive" option under tools menu to make a bootable usb drive....!!! OR use any other softwares like ISTOUSB(download this from www.istousb.com) to do this...!!

CHECK YOUR VAIO BIOS BOOT OPTION FOR EXTERNAL DEVICE BOOT ON!!!! FIRST

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.