Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm getting this error:

"This kernel requires an x86-64 CPU, but only detected an i686 CPU"

I have enabled:

  • Virtualization in BIOS
  • VT-x
  • Nested Paging

but I still get this problem while installing 64 bit Linux Mint Cinnamon over my 64 bit Windows 8.

My processor is an AMD A4-4300m.

share|improve this question
Did you check to make sure all the relevant BIOS settings are enabled? –  user55325 Sep 19 '13 at 3:44
i think so , its in virtual box , so i didnt change the secure boot etc options in BIOS. –  Somjit Nag Sep 19 '13 at 4:53
Sometimes there are other extensions than VT-x, like I/O virtualization (VT-d). If you have any of those, try disabling them (but leave VT-x enabled). Sometimes they cause problems. If they're already disabled, try enabling them. –  user55325 Sep 19 '13 at 5:00

1 Answer 1

In the VirtualBox settings for the virtual machine, on the general -> basic tab, make sure the "version" for the "linux" type is set to 64-bit and not 32-bit.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.