Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I got an external flash drive, plug into my school's lab for use, and came back noticing all my folders have gone missing! The space shown taken is still the same, then i played around with all Folder Options, unticked "Hide Protected Operating System files" option and voala! All my folders are there! I suspect some virus from the lab is messing with this, but is there a way i can revert this ?

share|improve this question

2 Answers 2

up vote 2 down vote accepted

That's because the folder is being assigned with the system attribute

Just open command promt with admin priviledge and run

attrib -s folder /D
share|improve this answer
    
Ok so i tried running just attrib on the flash disk root (F:), it doesn't show the list of folders that is assigned with system attribute. I some files with A attribute somehow. Any ideas? –  Jack-V Sep 19 '13 at 5:46
    
Ah i think i got it. Gotta remove the system , hidden, and read only attributes of the folder! Thanks for the help anyhow! –  Jack-V Sep 19 '13 at 5:58

In command prompt, type this:

attrib  -H -S F:\\*.* /S /D /L

Where F stands for the drive name. Change it base on the drive name you want to unhide operating system files.

P.S.: All caps; it won't work if you use the lower case.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.