Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I tried hard to install Internet Explorer 10 on my computer with Windows 7 Enterprise 64-bit. (It is a multilanguage version. The English is installed first, then language support packages are installed, and the tool is used to switch the language. After that, it has the Czech-language user interface.) No luck.

I did try it with Windows Update. The update was suggested, but it repeatedly ended with the "unknown error" with the code 9C57. After "Show help for the error" it says it searched for "WindowsUpdate_00009C57" and "WindowsUpdate_dt000". The situation repeat when I try second time... I tried also "clean boot" (i.e. msconfig.exe, off the "after start app", hide MS services, etc.) It did not help.

When installing from a standalone IE10-Windows6.1-x64-cs-cz.exe (about 47 MB), it downloads the required updates first, then it says I should go online and follow the http://support.microsoft.com/kb/2818833/en-us

The two of the mentioned packages (Windows6.1-KB2670838-x64.msu and Windows6.1-KB2786081-x64.msu) cannot be applied to my computer).

Exactly the same error appears when trying the en-us version (IE10-Windows6.1-x64-en-us.exe).

When looking inside the c:\Windows\IE10_main.log, I can find the lines:

02:12.040: INFO:    Prerequisite download processes have completed. Starting Installation of 6 prerequisites.
02:12.133: INFO:    Launched package installation: C:\Windows\SysNative\dism.exe /online /add-package /packagepath:C:\Windows\TEMP\IE1846B.tmp\KB2834140\Windows6.1-KB2834140-v2-x64.cab /quiet /norestart
02:33.973: INFO:    Process 'C:\Windows\SysNative\dism.exe /online /add-package /packagepath:C:\Windows\TEMP\IE1846B.tmp\KB2834140\Windows6.1-KB2834140-v2-x64.cab /quiet /norestart' exited with exit code 0x800F081E (-2146498530)
02:34.036: ERROR:   Error installing prerequisite file (C:\Windows\TEMP\IE1846B.tmp\KB2834140_amd64.MSU): 0x800f081e (2148468766)

Because of that, I have downloaded the Windows6.1-KB2834140-v2-x64.msu from the official download pages and tried to install it separately. It ends with a simple message telling me (loosely translated) "The update cannot be applied to your computer."

Then I have extracted the Windows6.1-KB2834140-v2-x64.cab from inside and launched the

"C:\Windows\system32\dism.exe" /online /norestart /logpath:"C:\tmp\a\log.txt" /add-package /packagepath:"C:\tmp\a\Windows6.1-KB2834140-v2-x64.cab" /ignorecheck

(It was launched from the cmd console with leveraged administrator rights.) It displayed the text in the sense (translated from Czech) "The package Package_for_KB2834140 is to be ignored because it is not valid for this bit copy." (The log file contains the English line...)

2013-09-19 09:40:35, Info                  DISM   DISM Package Manager: PID=6212 The package Package_for_KB2834140 is not applicable to the image. Continuing due to /ignorecheck switch. - CPackageManagerCLIHandler::Private_ProcessPackageChange

What else should I try to install the package and the Internet Explorer 10?

Update: I tried to follow the Ramhound's advice to uninstall all language packs (to install IE 10 with English only). However, I was probably not able to do that completely. The attempt to switch to the English. The Czech still remains as the default language somehow -- notice the text at the line with the yellow triangle. The full text says: "Language is the system language (default language of the user interface)." Anyway, the welcome screen speaks English and also the GUI uses English texts. The only exception is the content of the Windows Update windows. I guess it is a web application and the text may depend on something else than the installed UI language: The Windows Update window with Czech texts The update ends with the error that was observed earlier. Clicking the "Zobrazit nápovědu k této chybě" (Show the help for the error) still shows: The error details

share|improve this question
    
I didn't see where it was list. What is the main language of the system? I highly suspect your trying to install the wrong language file. I would remove the language packs until you have a base system, update to IE10, then install the language packs. –  Ramhound Sep 19 '13 at 11:47
    
Actually, the edition is probably Ultimate, but it is displayed as Enterprise. Definitely, I remember I did install the English first, and then I switched to Czech. –  pepr Sep 19 '13 at 11:53
1  
Alright...If it says Enterprise then its Enterprise Windows isn't confused about what it is. –  Ramhound Sep 19 '13 at 12:01
    
@Ramhound: The problem is that Enterprise should be activated via Volume License Key. I am very sure we do not have it. I am sure I did use a normal key that was available or via from MSDN or via Microsoft partner pages. –  pepr Sep 19 '13 at 12:31
1  
I find it unlikely that you used Windows Ultimate license and on a Windows Enterprise installation or any combination there of. –  Ramhound Sep 19 '13 at 12:38

2 Answers 2

I dont know if that makes a difference, but do you have an amd-cpu? Because the error includes amd64. Is it possible, that there are different downloads for different types of cpu?

share|improve this answer
    
Yes, this has also confused me. The processor is Intel Core 2. I tried but I never found the amd64 version. –  pepr Sep 19 '13 at 11:54
2  
@Chris - amd64 is a reference to the fact the x64 x86 extension is based on the work done by AMD. Intel actually licenses their design for their Intel x64 products. –  Ramhound Sep 19 '13 at 12:02
    
@pepr Have you downloaded them from here? –  c0dev Sep 19 '13 at 12:02
    
@Ramhound - Okay thx. I didn't know that. :) –  c0dev Sep 19 '13 at 12:03
1  
@pepr - Pick a single language and uninstall the rest. The entire point is to eliminate the language packs as the reason for your problems. They will be installed again after IE10 is working. –  Ramhound Sep 19 '13 at 12:37
up vote 0 down vote accepted

I do not know the reason why my Windows were crippled that much. Anyway, none of the suggestions above helped. This way I have taken the way described for example here -- How to Do a Repair Install to Fix Windows 7

The Windows 7 Enterprise Repair lesson learned

Warning: The article may be related to non-English Windows installations only. I suspect the English Windows users may not observe the problem that lead to the experience described below.

I should also emphasize, that it is related to the Enterprise and possibly also to Ultimate editions of the Windows 7. As far as I know, both editions differ only on volume vs. a single activation key licensing. Both of the editions share the capability to install more language packs. This way, you can change the Windows GUI to one of 30+ languages. In my case, I was using English plus Czech.

  1. Full backup. I did not need finally to use the full backup. Anyway, one should never try whether he or she is lucky this way. So, I recommend to make the full backup (via the Windows Action center -- the small flag at the right bottom part of your screen -- the taskbar icon).

  2. Language version. The old instalation (that I wanted to fix) was done from Windows 7 Enterprise DVD from MSDN, disc no 4655 from November 2009. This specific DVD contained the installer for the following languages: English, Czech, Hungarian, Polish, and Russian. It differs from ISO images for separate languages. The installer contains the first step where you choose the installation language, and it is apparently used and installed as the system language. In other words, it seemed later as if the original installation was made from the Czech DVD. This had consequences for the later steps.

  3. Updates changed the original to SP1. During the time of using the original installation, the Windows Update tool added all the SP1 enhancements, and the OS was marked as Windows 7 Enterprise Service Pack 1.

  4. The ISO image needed for the repair. Because of the step 2 and 3, the ISO image of the Czech Windows 7 Enterprise with SP1 had to be used for the repair. I tried first the English Windows 7 Enterprise with SP1, but it differs in the primary language and was refused. When trying the ISO for Czech Windows 7 Enterprise without SP1, the DVD was refused with explanation that I cannot upgrade to the older system (or a wording something like that).

  5. I did use the touchable, burned DVD, not the ISO image only. The description at the link on how to do the repair gives you the alternatives for having ISO only, or physical DVD. I did not try the ISO-only way. The article is really helpful and applicable as you probably do not to that every day, and it is good to know what is to be expected. Possibly minor differences were observed, but nothing surprising.

  6. It really took several hours. The installer warned that the process may take several hours. Being used to the pesimistic notes like that coupled with downloads and updates elsewhere, just a smile leaked from my lips. However, the warning is correct. It apparently depends on how many applications you have installed, and how complex they are (size and settings). The computer is a bit obsolete, upgraded once (Intel Core 2, 6420 at 2.13GHz; 4 GB RAM), anyway it seems to be heavily hard disk activity dependent, and the faster procesor may not make it much faster. It took about 8 hours (read it one full working day), rebooting often, you know. Just get ready for that fact, use another computer at the time if you need some work to be done, read a book, or plan to do something else during the process.

  7. Windows Update had to be run several times. The goal, i.e. the installation of Internet Explorer 10, was achieved via Windows Update tool (I did not need the standalone IE10 installation package). The Windows Update tool had to be rerun several times. Apparently the newer updates where not visible before the older were installed. So, do not be surprised.

Have a nice time, (and study a Linux-related literature ;)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.