Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

One of my installation (itunes) is failing because of a path not found.

The question:

I need to create a folder in C:\Windows\System32\DriverStore\FileRepository\ and copy to that new folder some files. I get access denied, I'm admin.. When I saw the privileges - only user System can write there but I've no idea how to acquire this user(I never created it).

Long story:

Itunes fails because it doesnt find the location of usbaapl64.inf. It looks for that file in C:\Windows\System32\DriverStore\FileRepository\usbaapl64.inf_amd64_neutral_ca639d07023cb608 which indeed doesnt exists, but I search where the installation get this path from (stored in some files/registry/device manager) and I didnt find where this path is store. I do have the location C:\Windows\System32\DriverStore\FileRepository\usbaapl64.inf_amd64_neutral_c111aaecb61e9a2b so what I though was to create that location and copy the files to there. I really tried everything in order to fix that failed installation, this is the last resort.

Among things I tried (I scanned google and apple support, so I dont really remember the most) to install previous release, update apple usb drivers from the driver manager, split the apple installation to 3 (application support, mobile device and itunes), restart win between uninstall & install, clean the computer from left overs with verities of programs, clean the registry(plus clean it from anything that contain ca639d07023cb608), and I guess more things that I probably forgot...

share|improve this question
    
you're approaching your problem incorrectly; you shouldn't be manually playing around with the driver file stores unless you know EXACTLY what you're doing. First ensure you're using the right iTunes bit version for your OS (64-bit for 64-bit kind of thing). Then go over this from Apple's support forums: discussions.apple.com/thread/2231186?start=15&tstart=0 –  Ƭᴇcʜιᴇ007 Sep 19 '13 at 17:05
    
Been there, done that. I tried everything, and I know this is not the way to solve this. But, I just want to fix that, I'm on it for 3 days now. So all I care is to solve this, which I believe will. –  nir Sep 19 '13 at 17:10
    
Out of curiosity, could you try the ninite.com installer for iTunes? –  ϺОŞΣŞ Sep 19 '13 at 17:20
    
Been where done what exactly? Please edit your question to include everything you've already done/tried, including what the results were, to keep us from suggesting things you already did. If you've really "tried everything", then there's nothing left for us to suggest. :) –  Ƭᴇcʜιᴇ007 Sep 19 '13 at 17:23
    
use pnputil.exe to install the driver. –  magicandre1981 Sep 19 '13 at 17:33

2 Answers 2

up vote 2 down vote accepted

Normal NTFS Permisions on folder C:\Windows\System32\DriverStore\FileRepository\ are System - Full Control, and Everyone - Read & Execute.

I you really want to copy into this directory you can do the following:

  • Right click the folder, click Properties
  • Click the Security tab
  • Click the Edit button.
  • Now add your account and give it Full Control
  • Click Ok
  • Click Yes at the "Windows Security"-prompt
  • At the "Error Applying Security"-prompt click Continue once and Cancel at the next
  • Click Ok at the "Windows Security"-prompt

You can now copy files/folder into this directory.

To get control over all the other directories you could "Get Ownership" of this folder but that's not recommended. (you already have read access of those)

share|improve this answer
    
I just saw the error and clicked cancel, but the continue and then cancel - worked! –  nir Sep 20 '13 at 7:42

You are going about this backwards. @Rik is answer will work, but here is a better way.

create a folder c:\driver copy all the driver files in

Go here: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion Find DevicePath Leave whatever is there alone but add

;c:\driver

The default is usually: %SystemRoot%\inf add the above gives you: %SystemRoot%\inf;c:\driver

Then repeat here: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion

Unplug and replug your device The Found new hardware wizard will launch find the drivers and load them into the directory you mentioned above automatically.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.