Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have been trying to remotely execute some scripts and run some programs on a remote virtual machine on a server. The command I have been using is Invoke-command After going through all the troubles to make it work properly with the right authentications and credentials and internal password, I now can finally invoke some executables from my local computer. However, as I was trying to run notepad.exe, it only showed up in the background processes, meaning that I couldnt see any notepad UI whatsoever. Does anyone know what the solution to this is ? Thank you!

share|improve this question

closed as off-topic by Daniel Beck Sep 19 '13 at 21:23

  • This question does not appear to be about computer software or computer hardware within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

2  
Already asked on SO:stackoverflow.com/questions/18902760/…. Please do not post the same question on multiple sites. –  EBGreen Sep 19 '13 at 19:31
1  
Please do not cross-post the same question to multiple sites of the SE network. –  Daniel Beck Sep 19 '13 at 21:23

1 Answer 1

up vote 0 down vote accepted

A solution using powershell, sadly I don't. I'd be glad to offer a bounty for someone else to find though!

For this, I use psexec. It's fairly simple to use and has a switch to run interactive processes.

While typing this answer, I saw this stackoverflow question, and the #1 answer is that it's a security limitation of powershell, so it may not be possible at all, even in the future.

share|improve this answer
1  
Oh if that's really the case then it's too bad. However thanks for the info though. I can use psexec but that requires the special tool sadly. –  FrozenLand Sep 19 '13 at 20:40
    
Hello Mike, Thank you for your post on Super user. I am still having some issues with Psexec. As it turned out, it also launches programs in the background. I have tried with several Windows built-in apps like mspaint.exe, notepad.exe and calc.exe but none of them seem to have any GUI visible to me. Is there an option for PsExec to make it run visibly? I have tried -i, but it still doesnt work. –  FrozenLand Sep 19 '13 at 21:00
    
@FrozenLand you might want to try psexec.exe -accepteula -s -i -h yourApp.exe, don't forget -accepteula or it will 'invisibly' hang there. –  BigHomie Sep 19 '13 at 21:10
    
I have tried that also. For some reason it just refuses to show up... It is frustrating –  FrozenLand Sep 19 '13 at 21:37

Not the answer you're looking for? Browse other questions tagged or ask your own question.