Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a computer running Windows 7 Professional 64-bit. It has a single account with admin rights. I don't really know when and why this happened, but I can't perform any admin task anymore:

  • Each time I try to run a program, e.g. Program.exe, as an admin, I get this error:

    Windows can't find 'C:\Path\to\Program.exe'. Check the spelling and try again.
    
  • When I try to run any software installer, I get:

    ShellExecuteEx failed, code 2.
    The system cannot find the file specified.
    

    Googling this message finds some results, but nothing helpful to me.

  • Clicking any admin task (with the shield icon) in the Control Panel either fails silently or produces a Windows can't find 'xyz'. Check the spelling and try again. message, so I can't get important (according to Windows) Windows updates, create a new account, etc.

I ran a Microsoft Security Essentials (which apparently is up to date) check, I can't install new software (such as CCleaner) nor launch a command with admin rights.

Do you have any ideas about what to do? Thanks in advance.

share|improve this question
    
Have you tried any of the steps suggested on Microsoft Forums‌​? I know it is not your exact problem, but a clean boot might help to track down your problem. Can you clarify your first bullet point, seems something is missing. –  Doktoro Reichard Sep 19 '13 at 21:23
    
Can you access the Local Users and Groups folder via Computer Management? –  Yassar Sep 19 '13 at 21:24
    
@DoktoroReichard Apparently, msconfig need admin right, so I can't run it –  corentin Sep 19 '13 at 21:32

2 Answers 2

It sounds like something is corrupt. Try to open an administrator command prompt and run:

sfc /scannow

This will verify the integrity of the Windows files and try to replace them if they are corrupt.

It might not be a bad idea to run a scan disk as well.

share|improve this answer
    
I can't open an admin command prompt ("Windows can't find c:\Windows\System32\cmd.exe", please check the spelling and try again") :-( –  corentin Sep 19 '13 at 21:33
    
Seems like a virus ate away your files... my suggestion would be to reinstall Windows all together (unless it is possible now to run cmd from the install disk) –  Doktoro Reichard Sep 19 '13 at 21:35
2  
I believe you can run sfc /scannow from outside of Windows if you use repair mode command prompt from an installation disc. –  Moses Sep 20 '13 at 1:25
    
Moses is correct –  surfasb Sep 20 '13 at 5:06

This answer might be a bit late - I had the same issue and it turned out to be because I was trying to run a setup as admin from one my regular user account's private folders (my admin user couldn't see it due to the way my system is setup)

I found this out by using the runas command (which is a command line tool for running a program as a different user).

I did this:

  1. Bring up a cmd.exe terminal
  2. runas /user:domain\myadminuser cmd.exe - this runs a cmd terminal as your admin user.
  3. then navigate to where your program is and run it.

I got an error when I tried to cd into the directory. Once I copied it to a different location, my admin user could see the application and run it.

If this doesn't help, you might try just running your app from the command line through runas (rather than using Windows UI version).

eg: runas /user:domain\myadminuser myprogram.exe

You might get a more usable error mssage at least.

Danny

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.