Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I open a C++ file and press C-space to try to select some codes, but it doesn't work now. And there's an error message at the bottom: symbol's function definition is void semantic-mrub-update. How to resolve this problem?

share|improve this question
1  
I assume that your goal is to enable set-mark-command using C-space. The function that is linked to your C-space is traceable to . . . lisp/cedet/semantic/mru-bookmark.el in the source code of a recent version of Emacs Trunk. If you search your configuration files and third-party installed libraries / packages, can you find a reference to a key definition that is linked to C-space and semantic-mrub-update or semantic-mrub-push? That key definition would be a likely suspect . . . – lawlist Sep 21 '13 at 3:43
    
I had this problem with Emacs (in the terminal) on Lubuntu (14.04.2), solved it by following the instructions in “ctrl+space” has been bound to invoke some input method and does not work in Emacs or Eclipse auto-complete. – zrajm May 31 '15 at 15:59

It is possible that there is a conflict with a shortcut defined within your desktop manager. The shortcut C-space is often mapped to switching keyboard input methods. You might want to change (or remove) that shortcut in the keyboard input method preferences. I had the same problem after switching to Ubuntu 14.04 and solved it this way.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .