Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running Ubuntu 13.04 64 bit w/ unity desktop

What I'm experiencing: When I turn on my computer, the Ubuntu loading screen appears but disappears in wake of a shell which I can log into.

Once logged in, I can start Unity via sudo start lightdm and subsequently login via unity gui.

However, the desktop software doesnt seem to be running. There is now tool-bar/menu-thing. I cannot use Alt+Tab to cycle between open windows, and I cannot restore windows which I minimize.

In every respect, I would have the same experience issuing sudo startx from an xterminal. I have reinstalled unity to no avail. installation seems to go just fine.

Any ideas on where I might go about addressing this problem? Thanks

linux ubuntu xwindows ubuntu-unity

share|improve this question
    
Side note: it's mostly a bad idea to run startx as root, i.e. using sudo startx. Is there a specific reason you're doing this? –  John Bensin Sep 20 '13 at 20:11
    
No, I noticed I couldnt start lightdm unless I was root, so I assumed the same was true with startx. In retrospect, I dont see why. Just out of curiosity though, what's bad about it? –  rocketas Sep 20 '13 at 20:51
    
In my (albeit limited) experience, it can really mess up permissions in your home directory. –  John Bensin Sep 20 '13 at 21:17

2 Answers 2

Try sudo dpkg-reconfigure lightdm.

If that doesn't work, try opening /etc/X11/default-display-manager in nano/whatever text editor you as root and replace whatever's in there with usr/bin/lightdm or "usr/sbin/lightdm. That should work after your reboot.

share|improve this answer

Maybe it's Compiz's problem.

  1. Install CompizConfig by pressing Ctrl+Alt+T and type sudo apt-get install ccsm

  2. Press Alt+F2 and type ccsm

  3. Go to the Window Management tab

  4. Check Application Switcher, Maximize, Move Window, Resize Window and Place Window

  5. Now go to the Effects tab

  6. Tick the box Window Decoration

  7. Go to Preferences

  8. In the Backend section, choose GSetting Configuration Backend

  9. Click Back and them Close

  10. Press Alt+F2 and type compiz --replace (After you type, the screen may flicker a bit) urati

  11. Go to the Dash, type Startup Applications

  12. Click Add and type compiz --replace at the Command section, in the Name section, type whatever name you like

Voilà, you can now switch windows using Alt+Tab.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.