Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My laptop is a Linux mint powered host and a windows 8 guest via VMware Workstation. Yesterday, I get the bad and stupid idea to upgrade my windows 8 to windows 8.1 final release, using the Installer from the ISO.

After everything installed, I logged into my guest windows 8.1, and surprise, I can't map VMWare Shared Folders as network drive, or simply see, as I could before, "vmware-host" in the list of network locations.

I supposed it could be an issue related to the "TrustedInstaller" user folders ownership, so I tried to update the ownership of system files to the "Administrators" group, but nothing changed.

Anyone has an idea of what can I do, before totally deleting my VM and start again with a new one from scratch? Thanks in advance

share|improve this question
    
What version of Vmware Workstation? They just released v10 which offers Windows 8.1 support. The Vmware tools probably get updated, and the Guest drivers. –  Zoredache Sep 20 '13 at 22:42
    
I'm using vmware 10, I know a clean vm windows 8.1 works as a sugar, but my problem has begun after I updated my guest windows 8 to windows 8.1 using the installer –  Hoghweed Sep 21 '13 at 0:00
    
After installing the VMWare tools you can shutdown the VM, edit the .VMX file replacing all occurances of "e1000e" with "vmxnet3" then see if things improve. This switches from an emulated Intel network card to a VMware paravirtualized NIC. –  Brian Sep 21 '13 at 4:11
    
reinstall the vmware tools in the VM. –  magicandre1981 Sep 21 '13 at 5:40
    
@magicandre1981 I've done three times but nothing changed.. I saw, while googlin about, thet the problem could be caused by a different set of permission given from the upgrade process... –  Hoghweed Sep 21 '13 at 13:58

2 Answers 2

First re-install the VMWare tool in the VM, either do a repair or un-install then install. After that goto settings and make sure the shared folders are "On" The shared folders are now available via: \vmware-host\Shared Folders For easy access in older Windows programs I created a mapped drive e.g. Z: to \vmware-host\Shared Folders

share|improve this answer

In my case, this issue was resolved when I installed the new version 9.6.1 of VMware Tools for Windows (Pre 2000) 9.6.1.

(My former work-around - which worked - was to configure a samba drive on my host and access it through the virtual network on my windows 8.1 guest.)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.