Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am running an Ubuntu 13.04 in the VirtualBox on Windows7. The network option is NAT.

The problem is I can use apt-get command to get some package on the internet like : curl. I can access those share computers on my Win7.

it is really wired that I just sent an email using Thunderbird. But I can not access internet through Firefox.

However, I can not access the internet through Firefox. And no response while ping www.google.com.

That's all!

share|improve this question
add comment

2 Answers

On the Settings for the Ubuntu VM change the network option to Bridged Adapter. Some information from the VirtualBox manual:

With bridged networking, VirtualBox uses a device driver on your host system that filters data from your physical network adapter. This driver is therefore called a "net filter" driver. This allows VirtualBox to intercept data from the physical network and inject data into it, effectively creating a new network interface in software.

The VirtualBox networking engine may not be working as intended, which may be causing the issues you're seeing.

Additional Info: An advantage of using the Bridged Adapter option is that it would make the VM appear as a physical device on your network, therefore allowing you to share folders/files just like you would be able to with a physical device. This is particularly useful when setting up a Server VM.

share|improve this answer
    
Hi, Thanks you. I just tried your idea. But still can not connect to internet. The internet connection tray (on the top right of the screen) turns into that like wireless connection from the double arrow. And massage says disconnected. And I even lost Thunderbird connection. when I ping www.google.com . It says "Ping unkown host www.google.com" –  leo Sep 22 '13 at 0:29
    
When you use the Bridged Adapter option, does the drop-down show the name of your physical adapter? For example, mine says Intel(R)..... –  Yassar Sep 22 '13 at 8:49
    
yes, the setting page like below: /////////////////////////////////////// Enable Network Adapter Attached to: Bridged Adapter Name: Inter(R) 82579LM Gigabit NetWork Connection Advanced Adapter Type:PCnet-FAST III(Am79C973) Promiscuous Mode:Allow VMs MAC Address:080027C3B7E Cable connected ///////////////////////////////// Still can not surf internet on Firefox. But can send email using Thunderbird. –  leo Sep 22 '13 at 10:31
add comment

It looks like you have not set up the DNS service on your Ubuntu guest. The following commands should take care of that.

sudo su
echo "nameserver 8.8.4.4" >> /etc/resolv.conf
echo "nameserver 8.8.8.8" >> /etc/resolv.conf
exit
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.