Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Yes, why can't I?

I was stashing away some old photography backup zips last night. I could copy 4 of my > 1 GB backup zips to my external USB connected hard-drive when I got the error message "Cannot copy file. Not enough free space." (sort of) for a zip of roughly 7 GB.

But there are 120 GB free. Why is this?

EDIT: Clarification - the files that I could copy was smaller than 4 GB. The failing one was 7 GB. The cause seems to be the FAT32 4 GB limit.

share|improve this question
1  
Consider removing irrelevant tags (backup, zip, memory) and adding tags 'filesystems', 'fat'. – Bender Nov 3 '09 at 7:25
    
Roger that, Bender! – Johann Gerell Nov 3 '09 at 7:29
up vote 15 down vote accepted

Maybe your External HDD is formatted as FAT? FAT-formatted drives can't see files larger than 4 GB, you'll have to reformat it as NTFS.

The maximum possible size for a file on a FAT32 volume is 4 GB minus 1 byte (232−1 bytes). Video applications, large databases, and some other software easily exceed this limit. Larger files require another formatting type such as NTFS.

FAT32 @ Wikipedia

Or you could split the zip file in two 3.5 GB parts.

share|improve this answer
    
That's spot on! – Johann Gerell Nov 3 '09 at 7:26

Most likely the drive has been formatted with FAT32 which has a maximum file size of 4GB. See the Wikipedia article on FAT32

Format the drive with NTFS and it should be good to go.

share|improve this answer

I formatted my 8gb flash card to exFAT as I haven't NTFS option in "format" menu. But it works fine!

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .