Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a portable HDD that is split into 2 NTFS partitions. For some reason, when I booted Linux (Ubuntu) to clean a locked virus on each partition, mounting was fine, and the virus was deleted. I tried booting to Windows XP afterwards, and what I found was that one of partitions became RAW, and I need the data on it.

For now I haven't touch the RAW partition. The other partition works fine.

Can someone suggest a way to recover the partition or the data inside it?

PS: freeware/open-source solutions are preferred.

Edit: Strangely enough, I tried to read the portable HDD on Windows 2003 Server, and it recognized the partition, but not with XP. I will backup all files before trying to fix the boot sector.

share|improve this question
    
What did you use to mount the partitions? Did you unmount the drives when you were done? – user3463 Nov 3 '09 at 7:46
    
i use Ubuntu (gnome desktop) file manager, double click on portable hdd drive and it mount automatically (linux end user, not an advance user), i did unmount before shut down – Dels Nov 3 '09 at 8:30

You might be able to recover your data with testdisk. It's available in ubuntu repositories.

share|improve this answer
    
tested the windows version, but i don't understand how it works to recover partition? i can access the partition and view the file list and what next? – Dels Nov 3 '09 at 8:25
    
They are tons of tutorials on the website i linked to ... here is one of them: cgsecurity.org/wiki/TestDisk_Step_By_Step – avelldiroll Nov 3 '09 at 9:04

Not positive if this would work but could you use the Windows command prompt convert command to convert it to the NTFS file system? I know this works between FAT, FAT32, and NTFS, but with RAW, couldn't hurt to try after you backup what you can access

share|improve this answer
    
I'd first try to change the partition type with e.g. fdisk – vonbrand Mar 5 '13 at 1:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .