Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've installed Google chrome on my new Windows 8. When I load some sites their behavior differs a little bit from that I have on Gooogle chrome on my windows xp machine. For example,

  1. This one has a feature called instant translate(translation occurs when you're typing). It doesn't work. I've opened chrome developer tools to figure out the problems. There was one. It sais that chrome failed yo load resource desktop_module_async.js resource. As I understand that js file performs instant translating

  2. youtube: when I open youtube the page renders, but all videos don't get played(also all preview pictures for videos don't get loaded). In Chrome console I see a lot of errors indicating Uncaught SyntaxError:Unexpected identifier

  3. Google+ when open the google+ I get the error page indicating that there were some problems during loading CSS
  4. Google maps Simply see the blank page and in the console: Failed to load resource

I have 29.0.1547.66 m version of chrome. On xp machine it is 29.0.1547.76 m version. When I try to update the version of Chrome on windows 8 machine I get error 7 complaining that downloded file has not passed the verification.

Have you any ideas what can cause such problems? P.S. On my windows xp machine there are no such problems

EDIT 1 Seems the problem relates to browser cache. Google sends different respones based on the version of operating system. I've found similar topic on superuser. When I cleared my cache everything works fine. Thanks to all

EDIT 2 No, cache doesn't cause such behavior. I cleared the cache, worked for some time, then reboot my laptop, opened Chrome and saw this again. Then I tried to clear all cache for all period, but it didn't help.

EDIT 3 Seems that this issue is not unique

In my case its not the Adblock extension because I have completely remove it. Also I have a wired connection, so it's not a hardware problem

So the question is still open!

share|improve this question
Do you have the most recent versions of Java (32 and 64 bit) & Flash? It usually causes this kind of problems. – matan129 Sep 22 '13 at 13:08
Adobe flash player site says that I have flash player already built into my Chrome. How do the described problems refer to java? – maks Sep 22 '13 at 13:14
Sorry, my bad, got a little confused. Java isn't related to this issue. Also, try to re-download Chrome to update it, not via the about window. It will take extra couple of minutes but Google syncs everything so it isn't that bad. – matan129 Sep 22 '13 at 13:18
@maks What happens if you disable the build-in flash plugin under chrome://plugins/ and use the normal installed flash plugin instead? Does it solve the youtube problem? – nixda Sep 22 '13 at 13:56
@nixda and how to say chrome to use the normal one? – maks Sep 22 '13 at 14:02

You must log in to answer this question.

Browse other questions tagged .