Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Several days ago, the charger for my ASUS K50IJ laptop (19V, 3.42A) died. So, I bought an Omega universal charger with 11 different plug-ins, but I managed to first use the wrong plug-in (I later saw in the instructions it was for IBM, 16V 3.5/3.36/4.5A).

It didn't charge, so I managed to find the right plug-in, but that didn't charge either. Then I tried a friend's original ASUS charger (that one worked previously), and that won't charge either. Plus, I could smell burning for a sec coming out of the laptop.

So, did I fry the charging unit in the laptop? Can that be repaired? Thanks!

share|improve this question
    
If you could smell something burning then you did indeed damage the laptop. The adapter you used provided more Amps then the hardware was designed to handle. –  Ramhound Sep 23 '13 at 13:25

1 Answer 1

up vote 0 down vote accepted

If you had a burning smell that doesn't sound good. Taking it to a laptop repair store they'll be able to tell you for sure what the problem is. It definitely sounds like you've toasted part of the laptop but I don't think anyone, without physical access to the laptop, will be able to tell you for sure what is wrong.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.