Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Running Oracle Linux 5.8 (which is just re-branded RedHat EL 5.8) I must change the From address. But we have scripts that use mailx which cannot be re-written to use any extra flags, so I'd like to use internal variables instead, which I see on the linux.die.net manpage on mailx is an alternative to the -r flag:

-r address
Sets the From address. Overrides any from variable specified in environment or startup files. Tilde escapes are disabled. The -r address options are passed to the mail transfer agent unless SMTP is used. This option exists for compatibility only; it is recommended to set the from variable directly instead.

(Source: http://linux.die.net/man/1/mailx)

How can we use these mailx variables? I tried adding this to /root/.mailrc, no go:

set from=FromAddress@Example.com

I also added that to /etc/mail.rc with no gold. So I am turning to you, SuperUsers...

share|improve this question

I just tested this in Ubuntu 14.04 and using the -S parameter worked for me:

-S variable[=value]
          Sets the internal option variable and, in case of a string option, assigns value to it.

So, the following command sets the from address to "test@exmaple.org":

echo "This is my test" | mail -S from="test@example.org" -s "This is my subject" "receiver@exmaple.org"
share|improve this answer

Neither using -r nor setting the from variable worked in my environment.

I always got something like:

send-mail: 550 5.7.1 ... Invalid from address ....

What worked for me was adding an sSMTP alias to /etc/ssmtp/revaliases, e.g.

accountname:root@machinename.example.com:smtp.example.com

share|improve this answer

Apparently it's not possible to set a mailx variable to do this. This is done with a Sendmail (or equivalent MTA) configuration. But unfortunately no Sendmail configuration was workable for us, and we have to use the -r flag.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .