Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Toshiba Pen Drive.

Whenever I plug it to a computer, it shows a message saying-

You need to format the drive before you can use it.

I have tried repairing it via the command prompt way as listed in this site:

How to repair Pen Drive

Diskpart>List Disk> Select Disk 2>Clean

But again the computer returns an error during the 'Clean' command. It says that the action cannot be completed because of an I/O error.

I have tried using Acronis Disk Director to create a partition in the pen drive and recover it but to no avail.

I have tried using a software called Find and Mount to recover a partition but again to no avail.

I tried using google. Cannot seem to find any other way. Please help!!

share|improve this question
2  
Can you not right click on it and select format? – Dave Sep 24 '13 at 13:56
    
Did you try formatting it as it suggests? Does it do this in every computer you plug it into (more than 1)? – Ƭᴇcʜιᴇ007 Sep 24 '13 at 14:09
    
@Dave rook -> Even after formatting once, it shows the same message again. Hence renders the device useless. techie007: Yes. I tried it in more than one computer. Shows the same message each time. – Piyush Sep 24 '13 at 14:15
1  
Sounds like it is broken. You could buy a new one (I will assume that you have no files on it since you did the reformat)... – Dave Sep 24 '13 at 14:24
    
Smash drive. Drop in trash. Buy new one. – Daniel R Hicks Sep 24 '13 at 15:29
up vote 1 down vote accepted

Really sounds like that drive is toast. If you can't format it with a utility like the HP USB Disk Storage Format Tool then it's likely to not be repairable.

Here is the link to the format tool however I don't think it will do any good if diskpart is failing to fix things. http://download.cnet.com/HP-USB-Disk-Storage-Format-Tool/3000-2094_4-10974082.html

share|improve this answer
    
It says "Device media is write-protected". Any other suggestions or ways to fix it? – Piyush Sep 24 '13 at 17:19
    
In diskpart you can clear the attributes by selecting the disk then typing "attribute disk clear" – mark brak Sep 24 '13 at 18:12
    
^did not help. shows the same message-> Media is write protected and there was some i/o error while cleaning. – Piyush Sep 24 '13 at 18:52
1  
I'm afraid not. He's dead Jim. – mark brak Sep 24 '13 at 19:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .