Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to get a launcher to show up on Arch linux with Gnome 3.8 but for some reason it doesn't show up on the menu. I have to strip down the version of the original sublime_text.desktop file

[Desktop Entry]
Name=Sublime Text
Exec=/opt/sublime_text/sublime_text %F
StartupNotify=true
Terminal=false
Type=Application
Icon=sublime-text
Comment=Test message

For some reason, no matter what I do it doesn't show up. I tried putting it both in /usr/share/applications/ and ~/.local/share/applications/ but neither work.

share|improve this question
    
You may want to try an absolute path to your icon (even though that isn't always necessary). Also, have you marked it executable (chmod +x myentry.desktop)? – nerdwaller Sep 24 '13 at 21:33
    
Yes, I've tried setting permissions to 0777. Didn't work. Good point with the icon but it's trivial as Gnome simply leaves the icon blank if it doesn't find one. I'm thinking it's more of an issue with Gnome 3.8 or some environment variable not set in Arch's Gnome package. – Ancarius Sep 27 '13 at 7:25

You must log in to answer this question.

Browse other questions tagged .