Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I tried recently to work with C# with Emacs24. I found I installed it with MELPA. Then I run it. Nothing happened. I wonder what went wrong. I think I don't have curl installed on my Windows machine. I downloaded some kind of curl but I don't know how to use it and link it to my Emacs. Please help.

share|improve this question

migrated from Sep 25 '13 at 3:28

This question came from our site for professional and enthusiast programmers.

1 Answer 1

up vote 2 down vote accepted

Two things spring to mind.

  1. Are you running the OmniSharp server? OmniSharp for Emacs relies on OmniSharp server for its completions. You can find it here. Compile it, and run it against a Visual Studio/Mono solution - e.g. OmniSharp.exe -s path/to/solution
  2. You mentioned curl - it needs to be in your windows PATH somewhere. Stick curl.exe in a folder (for example, C:\tools) and add C:\tools to your path. There are a couple of ways to do that.
    • You can add it to your path at the OS level (this link will show you how) and restart Emacs.
    • You can add to your PATH within Emacs with a bit of lisp. This will set your PATH environment variable within Emacs only. Add it to your dotemacs and evaluate it or restart Emacs.

      (setenv "PATH" (concat "C:/tools;" (getenv "PATH")))

I hope this helps and good luck - OmniSharp is awesome, and I use it daily.


share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.