Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have machine with an Asus P8H77 motherboard, which contains a series of SATA disks. One of them has grub2 installed, and boots Debian.

I have the boot disk defined as the priority in the bios, and disabled other boot options.

If I start the machine, it goes through the bios, right up until the point that the grub2 menu would display, then it reboots.

If I hit the key that allows me to select the boot drive at boot up, and choose the right drive, it reboots.

IF I hit the key that goes into the bios screen (Easy Bios), there is another option for choosing the boot device. If I use this to choose the right boot disk, it boots up fine. Note this isn't a configuration option, it is just another boot menu.

So in each of the three cases, the same boot disk is being chosen, but will only boot from it if I go to the bios first.

It is almost like there is a race condition, and the boot disk is not ready, and going into the bios gives it enough time to settle.

What could be causing this?

share|improve this question

1 Answer 1

I'm not sure exactly what would be causing that. I would have taken the exact same steps as you to figure it out. My first thought is to check for an updated BIOS. Perhaps it's a bug that the manufacturor has fixed.

Next I would clear the CMOS resetting the BIOS back to it's factory default and then setting the primary HDD to boot too again, perhaps some bit got flipped in the BIOS and it's struggling to get it fixed.

An unlikely solution but you could try re-installing Grub2, maybe the BIOS is picking the right drive but grub2 is failing before it prints anything.

Lastly you could install Grub2 on a different HDD, it doesnt necessarily have to be installed on the boot drive. Try installing it on the second drive and setting the BIOS to boot to the second drive.

Good Luck.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.