Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just installed new RAM into my laptop yesterday. (PC2700 RAM, AMD Athalon 64) Like a good super user, I ran Memtest86+ to make sure the new RAM was good. The results were unlike anything I had seen before: On the second pass, in the middle of test 8, memtest printed "Unexpected Interrupt - Halting" to the screen and died.

Unexpected Interrupt - Halting

Type:     Resvd     eax: 00000000
PC:    00004a49     ebx: 12100000
CS:    00000010     ecx: 00feffff
Eflag: 00000286     edx: 12100000
Code:  00000000     edi: 10e500020

I have never seen Memtest86+ crash like that. I ran the test again and it crashed, again in test 8, this time 4% in, without completing a single pass. Does this mean my RAM is bad, or is this indicative of a deeper issue?

EDIT: This was an older version of Memtest86+, I am downloading the newer version and testing now.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

First, be sure you are running the most current version of MemTest86, which is version 3.5 at the time of this writing.

Put your old RAM back in and run MemTest86 again. If MemTest86 crashes in the same way, then you know that the problem is not with the new RAM. If MemTest86 does not crash, then you have more testing to do.

If you have access to a different laptop that can use the new RAM you purchased, you should install the new RAM into that other laptop and run MemTest86 there. If Memtest86 crashes in the same way on that laptop, then you can be relatively sure that the problem is with the new RAM.

If you are unable to get access to any other hardware that can handle the new RAM, consider returning the new RAM where you got it from and getting some other new modules. If this is infeasible, you probably chose a poor vendor for RAM in the first place.

Also, you could also try using MemTest86+, whose current version is 4.00, which was released within the last six weeks. I believe that MemTest86+ is based on the original MemTest86, but is maintained by a different group. I know that I have had similar good experiences with MemTest86+ as well with the original MemTest86.

share|improve this answer
    
My mistake, I wasn't aware there was a + and a non + version. I am using an older version of Memtest86+. I will edit my question now and then try the newer version. –  Josh Nov 3 '09 at 14:25
    
heh, any software with a + in the name is usually a newer version or reimplementation of something older. C++, Notepad++, MemTest86+, ... you get the idea. :) –  quack quixote Nov 3 '09 at 14:34
1  
The older memtest86+ crashed with both old and new RAM. The newest memtest+ (version 4) reports bad RAM in test 5. So it looks like that was the cause. Thanks! –  Josh Nov 3 '09 at 15:32

Interesting problem.

It could be indicative of a hardware problem, but I'm inclined to check your copy of Memtest first.

  • Does the same copy of memtest run OK on other computers?

  • Does the same copy of memtest run OK on this computer with the old RAM?

  • Does a different copy of memtest run OK on this computer with this RAM? ("Another version" of memtest would be best, but "same version, downloaded separately & burned again" works too.)

Start there and then proceed with eleven81's suggestions regarding the hardware.

share|improve this answer
    
The same copy ran fine on other computers. The newest version of memtest didn't crash and indeed, reported bad RAM. –  Josh Nov 3 '09 at 15:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.