Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to setup my ISP router and my TPLink (TL-WR741N) router to share the same subnet. The ISP router is connected to a fiber optic cable (internet connection), and I'm running an ethernet cable from the ISP router LAN 1 port to TPLink router LAN 1 port. I have disabled DHCP on TPLink, and set it's IP to 192.168.1.2 since the ISP one is 192.168.1.1 . When I connect to the TPLink router with WiFi, I can ping other computers which are connected to the ISP router and the other way around I can also ping all IPs. But, I can't open any web pages. So I found out that the DNS is not working on the TPLink router. That can be fixed by manually adding DNS servers in the adapter properties on Windows.

But that's more like a quick fix. Is there any other way I can fix this on router level?

EDIT:

I forgot to mention that there are 2 places where I can add the DNS servers on the TPLink router. On the DHCP settings, which are disabled. And on WAN port settings which again is not used.

share|improve this question
    
I forgot to mention that there are 2 places where I can add the DNS servers. On the DHCP settings, which are disabled. And on WAN port settings which again is not used. (Updated the Post) And yes, I tried adding that as well. Same result. –  DzoniDev Sep 25 '13 at 11:21
1  
If your clients get IP configuration settings via DHCP from one of your routers then configure your router, so that it would hand out DNS server addresses in DHCP messages. –  Ashtray Sep 25 '13 at 11:34
    
They would normally get their DNS setting from a DHCP server. Is the "ISP router" a router or a modem? If it's a router and all of your LAN ports are bridged on both routers, the DHCP packets should travel over from the "ISP router" to any devices on the TPLink router. –  hololeap Oct 5 '13 at 23:34
add comment

1 Answer

After 2-3 restarts of both routers the TP-Link router started accepting the default DNS servers specified by the ISP (all in one) router. So I guess the issue is resolved.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.