Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I don’t like the behavior of the new tab page in Google Chrome 29+. How can I restore the old behavior?

The new tab page (if you have Google set as the default search engine) now shows the Google logo (or, apparently, the doodle of the day if there is one), a search box, and a few recently visited websites. It also added an Apps button to my favorites bar, seemingly the only way to access my apps page, which has easy access to things I use regularly (Calendar, Gmail, Docs, G+, Facebook, Feedly, Google News, Netflix, Play Music, Pandora, Drive, Keep, etc.) I don’t like this behavior. I actually don’t mind having the logo of the day and search box, but I want my apps linked to on my new tab page.

Is there any way to get the old behavior back? I checked the settings and it doesn’t seem like it’s possible to set chrome://apps to be the new tab page (which would restore the old behavior) or to configure the new new tab page to display apps instead of recently visited sites.

share|improve this question
2  
Interesting, I'm on the same build as you and I don't have the New™ New Tab Page. Can you try if this extension will do the job? –  Sathya Sep 25 '13 at 13:06
    
@Sathya What OS are you on? My home desktop is Win7 and I've noticed the newer tab page there. My work computer I'm currently posting from is Windows XP. I'm on the latest build, but my tab page is also still the same as it was. –  DanteTheEgregore Sep 25 '13 at 13:10
1  
@Zach I have Windows 7 at my workplace & Windows 8 on my home system, both don't have the New™ New Tab Page. –  Sathya Sep 25 '13 at 13:11
    
On a side-note, there's a new button on your favorite bar named "applications" which, if middle-button clicked, will mimic previous behaviour. –  Kwaio Sep 25 '13 at 13:48
1  
@Kwaio That's an unacceptable alternative, IMO. It requires a mouse click, while Ctrl+T can open a new tab. It also adds an extra thing to my favorites bar to work around removed features. Zach's answer is really the best option. –  Thomas Owens Sep 25 '13 at 14:06
show 2 more comments

8 Answers

up vote 95 down vote accepted

Please note: This solution no longer works as many of the features mentioned have been removed by the Chrome developers. It will be kept for posterity, but is no longer guaranteed to work as intended.


Update January 29, 2014: As of Google Chrome stable Version 32.0.1700.102 m this flag still appears to exist. chrome-internal://newtab does not appear to exist. chrome://apps still exists.

Update Feburary 21, 2014 As of Google Chrome stable Version 33.0.1750.117 m this flag appears to no longer exist. chrome://apps appears to still work. chrome://newtab directs users to the new newtab page.

To disable this feature, go to:

chrome://flags/

And hit Ctrl+F. Search for "Enable Instant Extended API". Click disabled in the dropdown below it, then click relaunch now. This should disable the new tab page. Change the flag to enabled if you'd like to re-enable it at any time.

Edit: Here's the flag:

chrome://flags/#enable-instant-extended-api

Thanks Jim Bergman.


Other possible solutions

  • Please see either drzaus's answer or niutech's answer for possible solutions involving Google Chrome extensions and other dark magic.

  • Rob Cooper has posted a work around with some more details about how to get rid of the annoying search engine on the new tab page in Google Chrome. Please see his answer for more details.

share|improve this answer
2  
Helpful. I also found the option to disable the stupid new dialog boxes. –  Thomas Owens Sep 25 '13 at 13:30
2  
I wish I could upvote this more. I stare at that screen a hundred times a day, so I was quite upset when it was different. –  HenryAdamsJr Sep 25 '13 at 14:25
11  
fair warning: Google has already said that this flag will be removed from Chrome once the new tab page has been field-tested, so this is a best a temporary fix. –  Michael Edenfield Sep 25 '13 at 17:02
3  
(hrm. the comment about the flag going away appears to have been edited out of the google groups thread, so there may be hope...) –  Michael Edenfield Sep 25 '13 at 17:08
3  
You can link directly to a setting: chrome://flags/#enable-instant-extended-api –  Jim Bergman Sep 29 '13 at 7:43
show 13 more comments

Another alternative is to use the Replace New Tab Page extension and set the new url to chrome://apps (which is the url from the new bookmark icon).

I assume this lets you take advantage of the other parts of the flag "Enable Instant Extended API" rather than disable it.

share|improve this answer
    
found this via guidingtech.com/8004/… –  drzaus Sep 27 '13 at 17:54
5  
I need something like chrome-search://most-visited/ –  Davut Gürbüz Sep 30 '13 at 11:10
1  
The side effect of using this or the New Tab Redirect extension is that it leaves chrome://apps in the OmniBox so you have to erase it before typing a new URL, that's a major speedbump. The fastest way to clear omnibox is to highlight it by hitting Ctrl+L but that's still an extra keystroke that's NOT in my muscle memory :( –  Dmitry Pashkevich Jan 18 at 21:49
1  
@DmitryPashkevich this is unfortunately true; you can alternatively use F6 if it helps you get used to it faster, which you might need to since Chrome removed the flag ;) –  drzaus Feb 24 at 18:30
    
+1 I'm on chrome Version 33.0.1750.117. I had that Enable Instant Extended API disabled earlier. But one fine day, it automatically disappeared from my chrome://flags page! Crazy right? So yes, this helped me! Thanks. It's a shame that this cannot be configured via chrome settings. –  Nikhil Patil Feb 27 at 6:37
add comment

DanteTheEgregore's answer doesn't work in Google Chrome 33+ because Google has removed that flag. However, you can revert the old New Tab Page by following my workaround:

  1. Install the New Tab Redirect extension
  2. Set the URL in options to: chrome-internal://newtab or chrome://apps
share|improve this answer
4  
newer versions of chrome have also the chrome-internal scheme removed –  Wimmel Jan 18 at 11:44
1  
There is no chrome-internal://newtab. They removed it. –  Derek 朕會功夫 Jan 18 at 21:43
    
Indeed, recently they have removed it. Comment on this issuse to tell them to revert it. –  niutech Jan 22 at 0:05
add comment

This is annoying the hell out of me as well - after some tinkering and reading the docs on Google. I've found a solution - one that Google might not like either..

Namely:

Your default search provider has the option to customise the New Tab page. If Google is your default search provider, you'll see a logo and search box like on www.google.com. If your default search provider isn't Google, you may see a different layout on the New Tab page.

  • Open "Settings".
  • Scroll down to "Search".
  • Under "Set which search engine is used when searching from the omnibox." select "Bing".

Open a new tab and enjoy the lack of Google.

NOTE: If you find you're not getting some results - you can make Google quickly accessible by adding a shortcut to Google via:

  • Open "Settings".
  • Scroll down to "Search".
  • Click "Manage search engines"

Under "Other search engines"..

  • Scroll to the bottom to where you can add a new entry.
  • Search Engine: Google
  • Keyword: go - it didn't seem to like 'g' on mine, but try
  • URL: https://www.google.com/#q=%s
  • Open a new tab - type "go" (hit delete if autocomplete kicks in) and type your search query. Hit enter and you're good to go.

Enjoy!

PS: This has been tested and confirmed good on version 32.0.1700.76.

UPDATE - 4th March 2014

I'm now running Chrome 33.0.1750.117, with my default search engine back to Google - and all is well, normal behaviour has resumed. However, I've heard others still have it.. I can only guess that if the above doesn't work - you've falling into some Google A/B test. :(

share|improve this answer
1  
Sadly this no longer seems to help in v33.whatever -- even with Bing it's the useless newtabpage, just without a logo. I even made a simple JS page redirecting back to google as an interstitial helper (just so I keep the "benefits" of using Google as my default), no dice. –  drzaus Feb 24 at 18:48
    
Interesting. I am running 33.0.1750.117 and my default search is back to Google - and I'm no longer getting the annoying issue.. I just figured they had listened to feedback and sorted it out. –  Rob Cooper Mar 4 at 11:55
    
"Broken" using 33.0.1750.146 m. Using anything other than google as the default search just shows the 8 'top sites' only. This is starting to remind me of the Internet Explorer anti-trust days... –  drzaus Mar 4 at 21:00
add comment

Alternatively to access the old interface of Google Search, open either of the following links in Chrome:

Get Classic Old Interface in Google Search (English)

Get Classic Old Interface in Google Search (Worldwide)

Opening either of the above mentioned links, will give you the old Google Search webpage instead of the new one.

Then bookmark the link by pressing "CTRL+D" keys in your browser window so that you can access it quickly whenever you want. You can also set it as your browser homepage.

Courtesy

share|improve this answer
add comment

In Google Chrome v33 you also can use this extension http://stylet.github.io/GLogo_deactivator/ . I hope it will be helpful.

share|improve this answer
add comment

You can also install this extension. It will show the apps when opening a new tab in Chrome:

https://chrome.google.com/webstore/detail/show-apps-in-new-tab/nohbdifokmdgjcbbeobglcbaifinhfip

share|improve this answer
5  
You're affiliated with this project. As per the faq, please disclose any and all affiliation when promoting a project in your answer. meta.stackoverflow.com/help/behavior –  DanteTheEgregore Sep 30 '13 at 12:36
add comment

I recommend using the StartHQ extension: https://chrome.google.com/webstore/detail/starthq/ilcpdgfepihaomggobhmfiimflngbcoh . It additionally allows you to customize all of the links, titles and pictures. So that you don't have to rely on the Chrome App Store anymore.

share|improve this answer
add comment

protected by slhck Feb 24 at 14:44

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.