Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently tried installing CentOS 6.4 on my (formerly Windows) workstation. Installation worked fine, but afterwards the screen resolution was stuck at 1024x768(screen should be able to handle 1680x1050).

I thought it was some kind of problem with the drivers, so I switched to the nvidia drivers(trying both the EPEL package installation method as well as just downloading the driver from the nvidia site and installing it that way(used http://pyrx.sourceforge.net/blog/103-installing-nvidia-driver-on-centos-6 for that one)), both methods have the same result though: my max resolution is now 848x480. I tried googling for an answer, but I haven't found a method that works yet. Can anyone help me fix this problem?

Specs

Graphics card: Geforce 9800GT

CPU: Intel i5 660 @ 3.33GHz

share|improve this question

1 Answer 1

Log in as root:

$gedit /etc/X11/xorg.conf


Section "Screen"
Identifier  "Default Screen"
DefaultDepth    24
Option  "UseDisplayDevice" "DFP"
Subsection  "Display"
   Modes    "1680x1050" "1280x720" "720x480"
EndSubSection
EndSection

Try modifying the modes to your desired resolution and restart the system. Please take a backup of the file before editing. Not sure it will work for you. It worked for me.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.