Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've recently purchased a VPN service which I'm connecting to with openVPN.

On Windows 7 I can connect on both UDP and TCP settings, but when I'm trying the same thing on Ubuntu 13.04, it gives me Initialization Sequence Completed but only UDP gives me access to webpages.

When I'm trying to connect to a webpage with TCP it just keep loading with nothing happening

I've tried many settings from around the net which also includes commands for iptables.

I've also tried importing my settings in network-manager-openvpn, network-manager-openvpn-gnome but this gives me the error "VPN-NAME" Failed because of invalid VPN secret

I'm pretty sure that the problem is somewhere in the Ubuntu configuration, but here is my openVPN config file:

client
dev tun
proto tcp
remote vpn.host.here 443
reneg-sec 0
resolv-retry infinite
nobind
persist-key
persist-tun
ca ca.crt
ns-cert-type server
tls-auth ta.key 1
auth-user-pass
cipher AES-256-CBC
verb 4
tun-ipv6
keepalive 5 30

I don't know what information or logs is usable to fix this problem, but I will add it to the question when needed.

Does anyone have a suggestion?

BTW I can't use the UDP method because the port used there is not open on the network I'm going to use it on. It need to be port 80 or 443.

share|improve this question
    
have you already unlocked the system keyring at the time you attempt to start the VPN connection? ubuntuforums.org/showthread.php?t=1193786 –  Frank Thomas Sep 26 '13 at 15:16
    
@FrankThomas I'm not quite sure what you mean. I've never been prompt to unlock the keyring on Ubuntu 13.04. –  QuakeDK Sep 26 '13 at 18:00
    
perhaps it has changed then. I gave up on ubuntu when unity came around, so can't tell you for sure. it is the leading answer when you google 'openvpn invalid VPN secret' though. –  Frank Thomas Sep 26 '13 at 18:02
    
When i've searched for a solution this fix has come up multiple times: alexmufatti.it/2011/02/14/networkmanager-openvpn-secrets-error but it does not work either. –  QuakeDK Sep 26 '13 at 18:05
    
@FrankThomas But I'm able to connect to the VPN with command line so it should be possible to make it work without network-manager-openvpn and network-manager-openvpn-gnome –  QuakeDK Sep 26 '13 at 18:20

1 Answer 1

Port 443 -TCP is already used by HTTPS, while 443-UDP is free. Same thing for port 80. You may check them with the command fuser.

share|improve this answer
    
"sudo fuser 80/tcp" does return something but same thing with 443 doesn't. If I understand this correct, it will never be possible to connect through TCP 443, which doesn't make sense, when the service is available at that port? –  QuakeDK Sep 26 '13 at 17:52
    
BTW the UDP settings is using port 3478 and 53 and because of that I need to connect with TCP which is using port 443. –  QuakeDK Sep 26 '13 at 18:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.