Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

After upgrading Windows 8 Enterprise to Windows 8.1 Enterprise (RTM), the store app won't launch anymore, hanging on the splash screen forever. Is there a trick to reset the store app or something? Restarting or killing the app didn't work. There are no error messages in the event logs (TWinUI/Operational etc.).

enter image description here

share|improve this question

4 Answers 4

up vote 3 down vote accepted

Found this on another forum. Open a command prompt and run the following:

powershell -ExecutionPolicy Unrestricted Add-AppxPackage
           -DisableDevelopmentMode 
           -Register $Env:SystemRoot\WinStore\AppxManifest.xml 

(All on one line.)

share|improve this answer
    
That did the trick! Thank you very much. –  Gene Oct 23 '13 at 10:53

Method 1: I would suggest you to download and run the New UI App troubleshooter and check if Windows Store works.

http://download.microsoft.com/download/F/2/4/F24D0C03-4181-4E5B-A23B-5C3A6B5974E3/apps.diagcab

Method 2: Check if the date, time and time zone are set according to your time and time zone.

Source

share|improve this answer
    
Thanks. The troubleshooter detected some corrupted files and repaired them, but that didn't fix the issue. Date & time settings are correct. –  Gene Sep 27 '13 at 11:30
    
Didn't work for me either, but I too had corrupted files. –  pqn Nov 14 '13 at 3:16

For People that are experiencing a similar problem, where you get an error message saying something like:

"We weren't able to connect to the Store. This might have happened 
    because of a server problem or the network....blah blah blah"

And the above methods will not work, here is the solution:

1.) Go to Settings

2.) Then Change PC Settings

3.) Then Your Account

4.) Then you should see a little link to the right that says Verify Your Identity

5.) Click that link, and type in your password that you use to login to your pc.

6.) Go to Task Manager to close the Store

7.) Profit!

Hope this helps!

I experienced this when using the 8.1 beta, when the beta expired and I tried to download the newest version of Windows I ran into this problem and searched, and searched, and searched.....and found many solutions like the ones above, until I finally came across a blog that described the above method.

share|improve this answer

Check your network connection, if you have google DNS server try remove it or put your gateway IP. I had this before problem but after I remove google DNS server (8.8.8.8) and I changed it to my router IP it fix the problem and windows store started.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.