Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Always, when I boot my system, I must witness a flash of error right before the GRUB menu pops up.

It goes like this:

Loading Operating System.
GRUB Loading.

Welcome to GRUB.

error ....

Then it continues to display the menu with no problems.

Is there a way to halt on the error, so I can see what's the error?

Also, I thought that I may get rid of the message by reinstalling grub, and reconfiguring, but that did not help, so, I want to track what it exactly is.

Though, it appears that the rest of the system is not harmed - further the boot is normal, no errors, everything's fast.

It's only the error I have to find out.

share|improve this question

Have you tried hitting the "pause" key on your keyboard, it may be the easiest way to get the error message.

Alternatively check the system log by running "dmsg", although not all boot errors get logged here.

share|improve this answer
Cannot seem to pause on the error. – joltmode Sep 30 '13 at 8:23

You can use GRUB's sleep command in grub.cfg like this:

set default=0
sleep --interruptible --verbose 60

Here 60 [seconds] is a sleep's duration, --interruptible (-i) allows to break sleep by pressing escape key, --verbose (-v) displays remaining seconds during countdown.

share|improve this answer
Does this allow you to do diagnostic things or does it just delay GRUB long enough to write down screen messages? Can you clarify how to use this to analyze the error? Thanks. – fixer1234 Feb 20 '15 at 9:19
Exactly, it just delays GRUB — in the right place, before the menu shows. Nice for troubleshooting minor errors and warnings like missing locale in a sibling post. I think you won't be able to miss real GRUB showstoppers :) There is no usable interface during sleep (other than ESC when using -i option), though this command can be used in the standard GRUB command line. – akamch Feb 20 '15 at 9:56
up vote 0 down vote accepted

Found the issue.

First off, had to reboot multiple times, trying to memorize the puzzle pieces of the error message to get the full message.

In the end it was: error: file '/boot/grub/locale/' not found.

Once that has been found, a quick Google search gave the result @

Successful solutions excerpt:

cp /boot/grub/locale/en\ /boot/grub/locale/

Though, also works.

Apparently, this appears to be a bug in Arch Linux'es GRUB2 package, though, not sure.

Anyhow, this fixes it.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.