Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've recently installed kubuntu 9.10 AMD x64, on an HP 6830s. The installation went smoothly, with only one problem: when I try to use the internet, it's incredibly slow. I couldn't install Firefox or anything that requires the internet. I have tried most of the solutions I found through Google, but none of them solves the problem.

What can I do?

share|improve this question

migrated from stackoverflow.com Nov 3 '09 at 18:02

This question came from our site for professional and enthusiast programmers.

    
what does ip -statistics l say? (after experiencing slow internet) –  artistoex Nov 30 '11 at 22:52
add comment

2 Answers 2

I'd suggest checking if IPv6 is enabled as a first step. Under the System menu, open Network Connections, select your interface, click Edit, click the IPv6 tab and make sure that Ignored is selected.

share|improve this answer
add comment

Your problem does not seem to be a problem of (K)Ubuntu, but of your router or ISP (see Launchpad for a looong bug report). Therefore, I advise you to not disable IPv6. While this might help in short term, he problem will probably hunt you down again in one or two years when IPv6 takes over from IPv4.

The first thing you should try is updating your router's firmware. This completely solved the problem for me (and others). If this doesn't help, you should bug either your ISP or the router's manufacturer until they fix things.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.