Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

i want to change the font color of everything i write in the linux terminals (eg the one accessible at ctrl+alt+f1) to green. my default tty font color is white, but i would like it to be green. i have tried

setterm -term linux -foreground green -clear

but this just changes the color of the cursor. i want to change the color of the font - so that it looks the same as the following xterm configuration:

xterm -foreground green
share|improve this question
    
FYI, CTRL+ALT+F1 would be /dev/TTY1/ –  LightlySalted Sep 28 '13 at 4:17
    
correct. is this always the case? –  mulllhausen Sep 28 '13 at 4:33

2 Answers 2

up vote 3 down vote accepted

just needed to include the -store setting. the following does the trick perfectly:

setterm -foreground green -store
share|improve this answer

add to

~/.bashrc

if [ "$TERM" = "linux" ]; then
    echo -en "\e]P0232323" #black
    echo -en "\e]P82B2B2B" #darkgrey
    echo -en "\e]P1D75F5F" #darkred
    echo -en "\e]P9E33636" #red
    echo -en "\e]P287AF5F" #darkgreen
    echo -en "\e]PA98E34D" #green
    echo -en "\e]P3D7AF87" #brown
    echo -en "\e]PBFFD75F" #yellow
    echo -en "\e]P48787AF" #darkblue
    echo -en "\e]PC7373C9" #blue
    echo -en "\e]P5BD53A5" #darkmagenta
    echo -en "\e]PDD633B2" #magenta
    echo -en "\e]P65FAFAF" #darkcyan
    echo -en "\e]PE44C9C9" #cyan
    echo -en "\e]P7E5E5E5" #lightgrey
    echo -en "\e]PFFFFFFF" #white
    clear #for background artifacting
fi

http://phraktured.net/linux-console-colors.html

share|improve this answer
    
i did this then ran . .bashrc and it seems to have enabled 16bit colors for my tty1, but the font color has not changed from the default white. do i need to issue another command to actually set the font color to green? –  mulllhausen Sep 28 '13 at 4:33
    
actually i think it just modified the default colors without adding anything new. they look better, but unfortunately its not an answer to my question. -1 –  mulllhausen Sep 28 '13 at 5:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.