Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When typing 4 or 6 on terminal window it changes the tab instead of writing the number. I am using Red Hat Enterprise Linux Workstation release 6.4 (Santiago). How can this issue be fixed?

Here are answers to Rik's questions

  • I am using console
  • In configure shortcuts there is only Switch to Tab 6 action which contains 6 character
  • I can type 6 in all other applications I have tried.
  • I am using bash
  • After bind -p | grep 6 there is "6": self-insert
  • 8 and 2 doesn't scroll. It prints the symbol as expected.
  • In csh the problem is same
  • In gnome-terminal 6 is printed
share|improve this question
1  
Curious. 4 is left and 6 is right on function keyboard. If you type 'ctrl + v' before the key you can see the code associated. You can try just to see if 6 is right arrow '^[[C' or actual six. – cfreire Oct 2 '13 at 0:06
    
After ctrl + v it doesn't show any code but changes the tab. – Ashot Oct 3 '13 at 6:01

Maybe something in your keybinding is messed up.
If you're on KDE, could you check the following: (If you're on Gnome, let me know)

  • In the terminal screen goto Settings
  • Choose Edit Current Profile
  • Goto the Keyboard-tab
  • Edit the default
  • Type in the textarea a 6 in the Input-box

What output do you get in Output-box? It should say 6.
If you got a 6 somewhere in the left column in that list above that, it doesn't belong there.

Edit:

If you get the input/output boxes you are probably using Konsole from Kde.

Some follow-up questions (you can edit your question with the answers):

  • Are you indeed using Konsole? Check Help>About ???.
  • If it is Konsole: Could you check Settings>Configure shortcuts? Is there a 6 (you can type 6 in the search to get all the 6's).
  • I take it you can type the 6's in all other applications?
  • Are you using a desktop or laptop?
  • What shell are you using? (You can type echo $0 to determine if bash, ksh etc...)
  • If in bash: could you do a bind -p | grep 6? You need to paste the 6 from another application because you can't type it. Is there a "6": self-insert?
  • Do the 8 and the 2 do something? (Like scrolling up/down if you have enough lines in terminal) Or do they work properly?
  • You could try a different shell. If you're in ksh try typing bash + enter
    If you're in bash try typing ksh enter. (or other combination)
  • And last (I know, it's a lot :)
    If you start the gnome-terminal (if it is still installed) can you type the 6?
share|improve this answer
    
After entering 6 in input the output was 6 too. It doesn't help after adding (6, 6) row on table – Ashot Oct 4 '13 at 5:14
    
I added some follow-up questions in my answer. I know it's a lot, but hey, that's troubleshooting. (you can edit your question with the answers) – Rik Oct 4 '13 at 8:57
    
I have updated the question – Ashot Oct 4 '13 at 16:04
    
I don't know console. I only have konsole and gnome-terminal. In konsole you switch between tabs with Shift+Right and Left. It could be your console mixes some keys up. (What happens if you do a Shift+Right ?) You could try to re-install the package for console. I think it is a problem with the package itself or the keybinding in that package because it only happens there. – Rik Oct 4 '13 at 20:03

As rik quoted the problem appears to be at keybinding,one of the solution can be checking the events which are mapped for the keybinding

You can modify the key-bindings for gnome-terminal using gconf-editor.

Look under: apps/gnome-terminal/keybindings

start gconf-editor and navigate to /apps/gnome-terminal/keybindings/help

Browse move tab left and move tab right and also check whether numpadkeys were mapped for changing tabs,if the keys were mapped change it accordingly

Sample Example for disabling a tab change can be found over here.

Hope it helps

share|improve this answer
    
Thanks for answer but I didn't find bindings for 4 or 6 there – Ashot Oct 4 '13 at 8:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .