Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running Debian testing x64 with all updates. I install quodlibet 2.4 from the repository and added mp3's to my library. When I play them, however, I receive an output error:

GStreamer output pipeline could not be initialized. The pipeline might be invalid, or the device may be in use. Check the player preferences.

As far as I know, I've installed the relevant packages:

aptitude install -R alsa-base alsa-utils quodlibet gstreamer1.0-fluendo-mp3 gstreamer1.0-alsa

and configured my sound properly. After installing the packages and running alsactl init, sound works properly in VLC and my web browsers.

The output pipeline field the Playback tab of quodlibet's Preferences was blank, so based on relevant posts I found while searching (1, 2), I tried these options individually, as well as leaving the field blank:

alsasink device=hw:0,0
alsasink device=hw:0,1
alsasink device=default
gst_pipeline = alsasink

The post on the Arch Linux forum (link #2 above) recommended running this command to determine the appropriate alsa device:

python -c 'import gst; print gst.element_factory_make("alsasink").probe_get_values_name("device")'

python -c 'import gst; print gst.element_factory_make("alsasink").probe_get_values_name("device")'

This gives me an error, however:

Traceback (most recent call last):  
File "<string>", line 1, in<module>
gst.ElementNotFoundError: alsasink

My system is running Python 2.7.5. What am I missing? How do I get quodlibet to play mp3 files?

share|improve this question

2 Answers 2

up vote 2 down vote accepted

Since you're using alsa, install version 0.10 of gstreamer's alsa plugin, not version 1.0.

aptitude install gstreamer0.10-alsa

and quodlibet should initialize the correct gstreamer pipeline immediately.

Quodlibet depends on version 0.10 of the other gstreamer plugins, as running apt-cache depends quodlibet will tell you:

jb@x:~$ apt-cache depends quodlibet
quodlibet
  Depends: python
  Depends: exfalso
  Depends: gstreamer0.10-plugins-base
  Depends: python-gst0.10
  Depends: gstreamer0.10-plugins-good
  Depends: gstreamer0.10-plugins-ugly
  Suggests: gstreamer0.10-plugins-bad
  Suggests: quodlibet-plugins
  Suggests: gstreamer0.10-gconf
 |Recommends: gstreamer0.10-alsa
  Recommends: <gstreamer0.10-audiosink>
    gstreamer0.10-plugins-bad
    gstreamer0.10-alsa
    gstreamer0.10-plugins-good
    gstreamer0.10-pulseaudio

Quodlibet 2.4 isn't compatible with version 1.0 of gstreamer's alsa plugin. Neither version of gstreamer's fluendo mp3 plugin are necessary either.

share|improve this answer

Quodlibet uses gstreamer 1.0 since version 3.0 (see here) so you need to install gstreamer1.0-alsa if you're using a later version.

Debian jessie/testing now uses v3.0.2 as of this post.

See the package list.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.