Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I never post questions like these because I can usually fix problems like this on my own, but I need help with this.

I own a Toshiba C850, running Windows 8, it's only months old. It works fine. But in the past 2 weeks, it has started to do something odd.

After a week of observing it's behaviour, what happens is it dims after 'X' minuet(s), regardless of me actively pressing keys, then after 'X' minuet(s), it will turn off the display. It will do this behaviour randomly, not all the time.

What I have figured out is, at random, it seems to be ignoring the fact I am pressing keys, and the track pad is being used. It will then dim the display as if not being used until I press a key or move the track pad. After this, it will turn off the screen like it is proceeding with whatever settings I have chosen in any power profile, and again, it will come back on if I move the track pad or press any key. Like I said, it does this at random, regularly.

Here are a list of culprits (applications) I have examined.

Toshiba Eco Utility - Alters some power profile settings; could have corrupted them. I've also taken it away, and the same happens, but it may have left some broken settings somewhere that I can't find.

cCleaner - Possibly has removed an important registry entry, or something else. Too diverse to be specific.

Synaptics - Might not be registering when I am only using the track pad, which seems to be what is happening, randomly.

BIOS update 6.70 - Around the time I updated the BIOS, this started to happen. The BIOS update has also been removed from Toshiba's driver update page since the update. Maybe just coincidence.

I have changed drivers for lots of things, and tested it out, and the same happens (including another issue with freezing, then stuttering, then makes a horrible dubstep like noise, for a second or two, that frightens the heck out of me, lol - still trying to fix this).

I don't want to reset everything, and reinstall gigabytes of updates and things to it again. It takes too long, and setting it up the way I like it takes days. I would be really irritated if I did reset it all and it did the same all over again.

If you have any suggestions, fire away. If you need any extra info from me, just ask.

Also, this is unrelated to the other dimming problem Windows 8 has. I have that setting turned off anyway.

And on another note, I don't want to disable screen dimming or turning off because it saves a lot of power. It only has less than 4 hours life, and that's already lame. I have tested trying this, and it worked. But it's not convenient. I'm going to try it again and see if it still prevents the issue.

Thanks.

share|improve this question
1  
Can you download an older BIOS version and re-flash it? –  Yassar Sep 28 '13 at 19:48
    
Been thinking of trying this, but I can't seem to find a way to do it. I'll look into the flashing app, and see if it has the option to downgrade. –  Delusphere Sep 28 '13 at 19:51
    
You could do it via your laptop's BIOS, if you are able to download the ROM file for an older BIOS version. You just need a USB stick with the ROM file in the root folder. –  Yassar Sep 28 '13 at 19:56
    
I'll try and find it. They removed the BIOS downloads for it not long after 6.70 came out. I'll see if I can find any archive of it and reinstall it via the BIOS. –  Delusphere Sep 28 '13 at 20:01
    
Annoyingly, I can only find the in windows update application for it. I found an official archive website for the BIOS, but it requires a password to download anything. Because of that, I can't gain access to the ISO for it. I tried URL tweaking to get it to work, and I could only still access the regular in windows update solution. –  Delusphere Sep 28 '13 at 20:20
show 5 more comments

1 Answer

Flashing the BIOS back to 6.60 seems to have worked. I have no idea why, but there you go! I have no way to know for certain, so I will keep testing it out. Thanks yassarikhan786.

share|improve this answer
    
After testing, the problem is still happening. Decided to reset everything, and start again. I don't think this will fix it to be honest. –  Delusphere Oct 1 '13 at 0:59
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.