Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My ubuntu can't be open to the webprocess create new folders. When I use GitHub.

Ubuntu 13.04 64bit folders: /var/www or /var/www/myapp

I used this terminal commands:

sudo adduser <username> www-data
sudo chown -R www-data:www-data /var/www
sudo chmod -R g+rw /var/www

myusername@killer:~$ sudo adduser myusername www-data    
The user `myusername' is already a member of `www-data'.

This commands is ok, if my Yii doesn't want to create new folders in the /var/www/myapp direction. So when I don't try use the Git. Because of the git (delete the runtime and assets folders)

I tried the above 2 terminal command with the /var/www/myapp path, but I've still got the problem.

So my problem is that, I can't set the permission on my /var/www or /var/www/myapp folders, inorder to the webprocess can create folders! At first time okay, the above terminal commands work well, but after my yii try create this two folders, it hasn't got any permission to create folders in /var/www/myapp

If I don't use the git, I don't have problems...

Screenshoot1 Screenshoot2

share|improve this question

1 Answer 1

If I understand correctly, you're having problems using nautilus to make changes to a folder. Try this:

gksudo nautilus
share|improve this answer
    
Not just the nautilus. But I find another solution. The problem was, that the apache2 doesn't have permission to write files and create folders... I created the assets and runtime folders. After this, I run the above shell command in the terminal (command line). Than I put the .gitignore files. –  Bóta László Oct 2 '13 at 20:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.