Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am brand new to linux, so pardon the ignorance. I recently installed Linux Mint 15 KDE edition, and i'm trying to install qtcreator. From what little i know of linux, i am to obtain software packages from a repository. In mint, i have the Software Manager application open, and when i search qtcreator or any combination of qt, nothing comes up. I also noticed that there is only 2000+ applications available. Did mint not set my software sources entirely? if not, what repositories should i be looking for. I was also looking for chromium, and that didn't exist either. I desperately want to stop using windows, but not being able to find programs along with some other issues, is making it very difficult for me.

EDIT: @Chris, i ran the update command and i got a TON of errors. Here is the output.

gawain-MS-7640 gawain # apt-get update
Get:1 http://packages.linuxmint.com olivia Release.gpg [197 B]
Hit http://dl.google.com stable Release.gpg                                    
Hit http://dl.google.com stable Release                                        
Get:2 http://packages.linuxmint.com olivia Release [17.7 kB]                   
Hit http://dl.google.com stable/main amd64 Packages                            
Hit http://dl.google.com stable/main i386 Packages                             
Get:3 http://packages.linuxmint.com olivia/main amd64 Packages [23.5 kB]       
Ign http://archive.ubuntu.com olivia Release.gpg                               
Ign http://security.ubuntu.com olivia-security Release.gpg                     
Get:4 http://packages.linuxmint.com olivia/upstream amd64 Packages [9,249 B]   
Ign http://archive.canonical.com olivia Release.gpg                            
Get:5 http://packages.linuxmint.com olivia/import amd64 Packages [39.0 kB]     
Ign http://archive.ubuntu.com olivia-updates Release.gpg                       
Ign http://security.ubuntu.com olivia-security Release                         
Ign http://archive.canonical.com olivia Release                                
Get:6 http://packages.linuxmint.com olivia/main i386 Packages [23.5 kB]        
Ign http://dl.google.com stable/main Translation-en_US                         
Ign http://dl.google.com stable/main Translation-en                            
Ign http://archive.ubuntu.com olivia Release                                   
Get:7 http://packages.linuxmint.com olivia/upstream i386 Packages [9,237 B]    
Get:8 http://packages.linuxmint.com olivia/import i386 Packages [39.9 kB]      
Ign http://archive.ubuntu.com olivia-updates Release                           
Ign http://packages.medibuntu.org olivia Release.gpg                           
Ign http://packages.medibuntu.org olivia Release                               
Ign http://packages.linuxmint.com olivia/import Translation-en_US              
Ign http://packages.linuxmint.com olivia/import Translation-en                 
Ign http://packages.linuxmint.com olivia/main Translation-en_US                
Err http://archive.canonical.com olivia/partner amd64 Packages                 
  404  Not Found [IP: 91.189.92.191 80]
Ign http://packages.linuxmint.com olivia/main Translation-en                   
Err http://archive.canonical.com olivia/partner i386 Packages                  
  404  Not Found [IP: 91.189.92.191 80]
Ign http://packages.linuxmint.com olivia/upstream Translation-en_US            
Ign http://packages.linuxmint.com olivia/upstream Translation-en               
Ign http://archive.canonical.com olivia/partner Translation-en_US              
Ign http://archive.canonical.com olivia/partner Translation-en                 
Err http://security.ubuntu.com olivia-security/main amd64 Packages             
  404  Not Found [IP: 91.189.92.181 80]
Err http://security.ubuntu.com olivia-security/restricted amd64 Packages       
  404  Not Found [IP: 91.189.92.181 80]
Err http://security.ubuntu.com olivia-security/universe amd64 Packages         
  404  Not Found [IP: 91.189.92.181 80]
Err http://security.ubuntu.com olivia-security/multiverse amd64 Packages       
  404  Not Found [IP: 91.189.92.181 80]
Err http://security.ubuntu.com olivia-security/main i386 Packages              
  404  Not Found [IP: 91.189.92.181 80]
Err http://security.ubuntu.com olivia-security/restricted i386 Packages        
  404  Not Found [IP: 91.189.92.181 80]
Err http://security.ubuntu.com olivia-security/universe i386 Packages          
  404  Not Found [IP: 91.189.92.181 80]
Err http://packages.medibuntu.org olivia/free amd64 Packages                   
  404  Not Found
Err http://security.ubuntu.com olivia-security/multiverse i386 Packages        
  404  Not Found [IP: 91.189.92.181 80]
Ign http://security.ubuntu.com olivia-security/main Translation-en_US          
Ign http://security.ubuntu.com olivia-security/main Translation-en             
Err http://packages.medibuntu.org olivia/non-free amd64 Packages               
  404  Not Found
Ign http://security.ubuntu.com olivia-security/multiverse Translation-en_US    
Err http://packages.medibuntu.org olivia/free i386 Packages                    
  404  Not Found
Ign http://security.ubuntu.com olivia-security/multiverse Translation-en       
Err http://packages.medibuntu.org olivia/non-free i386 Packages                
  404  Not Found
Ign http://security.ubuntu.com olivia-security/restricted Translation-en_US    
Ign http://security.ubuntu.com olivia-security/restricted Translation-en       
Ign http://security.ubuntu.com olivia-security/universe Translation-en_US      
Ign http://packages.medibuntu.org olivia/free Translation-en_US                
Ign http://security.ubuntu.com olivia-security/universe Translation-en         
Ign http://packages.medibuntu.org olivia/free Translation-en                   
Ign http://packages.medibuntu.org olivia/non-free Translation-en_US            
Ign http://packages.medibuntu.org olivia/non-free Translation-en               
Err http://archive.ubuntu.com olivia/main amd64 Packages                       
  404  Not Found [IP: 91.189.92.201 80]
Err http://archive.ubuntu.com olivia/restricted amd64 Packages
  404  Not Found [IP: 91.189.92.201 80]
Err http://archive.ubuntu.com olivia/universe amd64 Packages
  404  Not Found [IP: 91.189.92.201 80]
Err http://archive.ubuntu.com olivia/multiverse amd64 Packages
  404  Not Found [IP: 91.189.92.201 80]
Err http://archive.ubuntu.com olivia/main i386 Packages
  404  Not Found [IP: 91.189.92.201 80]
Err http://archive.ubuntu.com olivia/restricted i386 Packages
  404  Not Found [IP: 91.189.92.201 80]
Err http://archive.ubuntu.com olivia/universe i386 Packages
  404  Not Found [IP: 91.189.92.201 80]
Err http://archive.ubuntu.com olivia/multiverse i386 Packages
  404  Not Found [IP: 91.189.92.201 80]
Ign http://archive.ubuntu.com olivia/main Translation-en_US
Ign http://archive.ubuntu.com olivia/main Translation-en
Ign http://archive.ubuntu.com olivia/multiverse Translation-en_US
Ign http://archive.ubuntu.com olivia/multiverse Translation-en
Ign http://archive.ubuntu.com olivia/restricted Translation-en_US
Ign http://archive.ubuntu.com olivia/restricted Translation-en
Ign http://archive.ubuntu.com olivia/universe Translation-en_US
Ign http://archive.ubuntu.com olivia/universe Translation-en
Err http://archive.ubuntu.com olivia-updates/main amd64 Packages
  404  Not Found [IP: 91.189.92.201 80]
Err http://archive.ubuntu.com olivia-updates/restricted amd64 Packages
  404  Not Found [IP: 91.189.92.201 80]
Err http://archive.ubuntu.com olivia-updates/universe amd64 Packages
  404  Not Found [IP: 91.189.92.201 80]
Err http://archive.ubuntu.com olivia-updates/multiverse amd64 Packages
  404  Not Found [IP: 91.189.92.201 80]
Err http://archive.ubuntu.com olivia-updates/main i386 Packages
  404  Not Found [IP: 91.189.92.201 80]
Err http://archive.ubuntu.com olivia-updates/restricted i386 Packages
  404  Not Found [IP: 91.189.92.201 80]
Err http://archive.ubuntu.com olivia-updates/universe i386 Packages
  404  Not Found [IP: 91.189.92.201 80]
Err http://archive.ubuntu.com olivia-updates/multiverse i386 Packages
  404  Not Found [IP: 91.189.92.201 80]
Ign http://archive.ubuntu.com olivia-updates/main Translation-en_US
Ign http://archive.ubuntu.com olivia-updates/main Translation-en
Ign http://archive.ubuntu.com olivia-updates/multiverse Translation-en_US
Ign http://archive.ubuntu.com olivia-updates/multiverse Translation-en
Ign http://archive.ubuntu.com olivia-updates/restricted Translation-en_US
Ign http://archive.ubuntu.com olivia-updates/restricted Translation-en
Ign http://archive.ubuntu.com olivia-updates/universe Translation-en_US
Ign http://archive.ubuntu.com olivia-updates/universe Translation-en
Fetched 162 kB in 17s (9,272 B/s)
W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/olivia-security/main/binary-amd64/Packages  404  Not Found [IP: 91.189.92.181 80]

W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/olivia-security/restricted/binary-amd64/Packages  404  Not Found [IP: 91.189.92.181 80]

W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/olivia-security/universe/binary-amd64/Packages  404  Not Found [IP: 91.189.92.181 80]

W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/olivia-security/multiverse/binary-amd64/Packages  404  Not Found [IP: 91.189.92.181 80]

W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/olivia-security/main/binary-i386/Packages  404  Not Found [IP: 91.189.92.181 80]

W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/olivia-security/restricted/binary-i386/Packages  404  Not Found [IP: 91.189.92.181 80]

W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/olivia-security/universe/binary-i386/Packages  404  Not Found [IP: 91.189.92.181 80]

W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/olivia-security/multiverse/binary-i386/Packages  404  Not Found [IP: 91.189.92.181 80]

W: Failed to fetch http://archive.canonical.com/ubuntu/dists/olivia/partner/binary-amd64/Packages  404  Not Found [IP: 91.189.92.191 80]

W: Failed to fetch http://archive.canonical.com/ubuntu/dists/olivia/partner/binary-i386/Packages  404  Not Found [IP: 91.189.92.191 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/olivia/main/binary-amd64/Packages  404  Not Found [IP: 91.189.92.201 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/olivia/restricted/binary-amd64/Packages  404  Not Found [IP: 91.189.92.201 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/olivia/universe/binary-amd64/Packages  404  Not Found [IP: 91.189.92.201 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/olivia/multiverse/binary-amd64/Packages  404  Not Found [IP: 91.189.92.201 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/olivia/main/binary-i386/Packages  404  Not Found [IP: 91.189.92.201 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/olivia/restricted/binary-i386/Packages  404  Not Found [IP: 91.189.92.201 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/olivia/universe/binary-i386/Packages  404  Not Found [IP: 91.189.92.201 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/olivia/multiverse/binary-i386/Packages  404  Not Found [IP: 91.189.92.201 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/olivia-updates/main/binary-amd64/Packages  404  Not Found [IP: 91.189.92.201 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/olivia-updates/restricted/binary-amd64/Packages  404  Not Found [IP: 91.189.92.201 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/olivia-updates/universe/binary-amd64/Packages  404  Not Found [IP: 91.189.92.201 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/olivia-updates/multiverse/binary-amd64/Packages  404  Not Found [IP: 91.189.92.201 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/olivia-updates/main/binary-i386/Packages  404  Not Found [IP: 91.189.92.201 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/olivia-updates/restricted/binary-i386/Packages  404  Not Found [IP: 91.189.92.201 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/olivia-updates/universe/binary-i386/Packages  404  Not Found [IP: 91.189.92.201 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/olivia-updates/multiverse/binary-i386/Packages  404  Not Found [IP: 91.189.92.201 80]

W: Failed to fetch http://packages.medibuntu.org/dists/olivia/free/binary-amd64/Packages  404  Not Found

W: Failed to fetch http://packages.medibuntu.org/dists/olivia/non-free/binary-amd64/Packages  404  Not Found

W: Failed to fetch http://packages.medibuntu.org/dists/olivia/free/binary-i386/Packages  404  Not Found

W: Failed to fetch http://packages.medibuntu.org/dists/olivia/non-free/binary-i386/Packages  404  Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead.

i have not installed or done anything at all to this fresh install of Mint with KDE. Is this something people always deal with right off the bat with linux?

share|improve this question
    
update your package-list apt-get update. Now there should be more –  c0dev Sep 29 '13 at 1:56
    
Try the following: First run: sudo rm /var/lib/apt/lists/* -fv than run sudo apt-get update. –  c0dev Sep 29 '13 at 2:11
    
exact same error dialog. No dice :\ . After installing mint, was there any steps i needed to take before installing software? when i said i had done nothing, i mean the first thing i did after loading mint for the first time was open the software manager and look for chromium, qtcreator, and mumble, of which i found none :\ –  FatalCatharsis Sep 29 '13 at 2:19

1 Answer 1

You can download and install qcreator without the software-manager. Follow this tutorial to download and install it:

First download Qt 5.0.1 from http://qt-project.org/downloads. I'm using a 32bit machine so I'll select that and download the file qt-linux-opensource-5.0.1-x86-offline.run. To install the .run file, right click for terminal in the directory containing the installer and type:

chmod u+x qt-linux-opensource-5.0.1-x86-offline.run
sudo ./qt-linux-opensource-5.0.1-x86-offline.run

Let it install with all default settings.(update: In Mint 15 with Qt 5.0.2, it’s default installation directory is /home/username/Qt5.0.2. It’s weird to put it there so I’d recommend changing it to /opt/Qt5.0.2)

Now if you just try to run Qt Creator now you'll realize you can't open the application(update: this seems to be fixed with Qt 5.0.2… or Mint 15). That's because there seems to be some faulty linking problem thing going on. To fix this, you'll create your own custom launcher.

Right click your desktop and select "Create Launcher...".

  • Type = Location
  • Name = Qt Creator
  • Location = /opt/Qt5.0.1/Tools/QtCreator/bin/qtcreator

now if you navigate to the qt5 directory and type "png" you will be able to find the Qt Creator logo. Just drag and drop it to that red rocket, press "ok" and you have your launcher set up.

Now, you should be able to run Qt creator but unable to build and run anything. That’s because lots of dependencies are missing. You would think that by installing Qt 5.0.1 they would install the dependencies as well but they don’t. Now open up the terminal and copy paste this:

sudo apt-get install build-essential sudo apt-get
install libx11-xcb-dev libglu1-mesa-dev libxrender-dev

Now when you open Qt Creator it complains up to 3 times some .xml file and no permission access denied thing and complains 3 times(exact same things) when it closes. Strange problem. So navigate to your home folder, reveal hidden files(Ctrl-H) and navigate to /.config/QtProject

Open a terminal there and type

sudo chown -R username qtcreator

And so, there you have it. Qt 5.0.1 and Qt Creator 2.6.2 running happily.

Now if you do use the examples(opt/Qt5.0.1/5.0.1/gcc/examples), you'll realized that you do not have permission to access it. Why? I don't know. But to change it go to "opt/Qt5.0.1/5.0.1/gcc" right click and open terminal and type

sudo chown -R username examples

Where "username" is the name of the user you wish to transfer full permissions to.

Source

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.