Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Okay, so I know that these kind of questions are pretty popular on StackExchange, but please hear me out. I have a belkin router, model F9K1102 v1. I also have a Westell Dual Connection modem, model A90-220015-04. Now, I have done port forwarding before, although it was with the same modem and a different (Cisco) router. My modem is IP 192.168.0.47 and my router is 192.168.2.1. I followed the following tutorial to set up port forwarding on the Belkin router:

http://portforward.com/english/routers/port_forwarding/Belkin/F9K1102v1/Apache.htm

And set up the following under "Virtual Servers":

http://i.stack.imgur.com/xAJ4Y.png

Yet, whenever I try accessing my public IP (from whatsmyip.org) via my iPhone on 4G, it can't find the server. The connection times out. Online port sniffers say that port 80 isn't open. This is becoming very frustrating and I really need it to work. Verizon is my ISP and I am running Ubuntu Server 12.04, btw.

Any help towards resolving this would be GREATLY appreciated. Thanks in advance!!

share|improve this question

migrated from serverfault.com Sep 29 '13 at 3:02

This question came from our site for professional system and network administrators.

    
have you confirmed that you have a service running on port 80 on the computer the NAT forwarding rule points to, the computers firewall allows it, and the service is configured to accept requests from 0.0.0.0? if not, the port will report as closed even if the nat rule is working perfectly. Also some ISPs don't allow port 80 incoming (unsolicited). have you tried another port, perhaps between 2048 and 10000? also, restrict your rule to TCP. try to avoid UDP allows in NAT if possible. –  Frank Thomas Sep 29 '13 at 3:23
    
My router port forwards to 192.168.2.38, and if I put that in my address bar within the network, my website comes up. I have firewall disabled on my router. That last thing you mentioned about accepting request from 0.0.0.0, how would I check for that? –  Nickersoft Sep 29 '13 at 3:36
    
run 'sudo netstat -ntlup | grep 80'. under local address for the httpd process, is it 0.0.0.0, 192.168.2.38, or 127.0.0.1. httpd.apache.org/docs/trunk/bind.html. your VirtualHost and htaccess. files can impact reachability as well. –  Frank Thomas Sep 29 '13 at 3:46

1 Answer 1

You have two routers, each routing and doing NAT because your modem is also a router. Your modem is doing NAT from the Internet to a 192.168.0.0/24 LAN between your modem and your router. Your router is doing NAT from that LAN to a 192.168.2.0/24 LAN that your other devices are connecting to. So you'll have to port forward on both of them. On the modem, port forward to the router's address on the 192.168.0.0/24 LAN. On the router, port forward to the machine.

However, it makes a lot more sense to make your setup sane. Pick a device to route and switch the other to just bridging.

share|improve this answer
    
David is absolutely correct. If you don't have admin access to the modem, call your provider and ask them to put it in bridge mode for you. This is a fairly common request and they can do it in a few minutes. –  jerm Sep 29 '13 at 18:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.