Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'd like to change the default font in Cocoa Emacs on OSX.

I know that in X11 emacs, one can just configure the defaults in an XResources file and they will apply to all frames. In Windows, it's possible to use registry settings to do the same thing. However, I couldn't find a way of doing that on OSX. Is it possible?

I'd rather keep my font settings outside of lisp if possible.

share|improve this question
    
Please include both the lisp line you used and the error you received. We can't read your mind. –  terdon Sep 29 '13 at 15:03
    
In addition to the example below by @lawlist, here is the link to the official documentation that provides an example of how to set font using the default-frame-alist: gnu.org/software/emacs/manual/html_node/emacs/Fonts.html –  lawlist Sep 29 '13 at 15:49
    
@terdon: In the question, I indicated that I was looking for an alternative to XResources/Registry that works on OSX with the Cocoa version of Emacs. –  Alan Pearce Sep 29 '13 at 16:08
1  
Editing the .emacs file should work in all cases. Including the error you get can help us understand why it's not working. –  terdon Sep 29 '13 at 16:16

1 Answer 1

(set-face-attribute 'default nil :background "black" :foreground "white"
  :font "Courier" :height 180)
share|improve this answer
    
This causes the same error I mentioned in the question and doesn't set the font correctly. Is there some particular way to call it to get it to work with the daemon? –  Alan Pearce Sep 29 '13 at 16:03
    
As @terdon suggested, you need to provide everyone with your error message exactly as it appears. –  lawlist Sep 29 '13 at 16:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.