Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have setup a local shared folder between my Macbook Pro (OSX 10.8.4 Mountain Lion) and my Desktop PC (Windows 7 Professional Service Pack 1 64 bit).

On my Mac, the configuration looks like this:

Mac configuration

And on my PC, I can browse to, and read and write to that folder without any issues.

However - when I try to open files on my mac that have been placed in the folder by my PC - I get this error:

error

What gives?

Bonus question:

How do I setup a Staff user for my PC so that I don't have to let Everyone Read & Write?

share|improve this question

2 Answers 2

One thing I would try (even though you dont have any issues connecting to the Mac share from the PC) is changing the sharing protocol from AFP to Samba. If you click the options button in the file sharing settings screen it will give you the option to pick between SMB and AFP. I could see there possibly being some strange permission thing in AFP that windows is trying to write when you save a file from the PC > Mac. When OS X tries to open it, it does not know how to read the permission that windows is setting and you end up with that error.

Another thing I would try is to make sure that the Everyone security group is being set on the files in Windows before you copy them over to the mac.

If you want to see an example, here is what I am talking about in regard to adding the everyone account to files/folders in Windows before copying them over

enter image description here

While I do not suggest adding this permission to all files on your system, do a test run where you add the everyone group to a file in WIndows, copy the file to the Mac and try to open it.

If that does not work, could you do a Get Info on one of the files you copied over to the mac and post the results in regard to any permissions the Mac can see on the file?

share|improve this answer
    
I did enable SMB prior to creating this question - so that is (probably?) not the issue. However - I am very interested in your second idea, Can you elaborate? –  anwyatt Sep 29 '13 at 23:59
1  
Well, you may have enabled SMB, but the screenshot shows you accessing it via AFP. I'm assuming that Richie086 means that you should try accessing it with SMB://10.139.2.102 instead. –  Debra Oct 1 '13 at 6:02
    
Exactly! Thank you for clarifying –  Richie086 Oct 2 '13 at 7:40

Here is my work around.

Right click the directory that your files and or other folders are in and as above make sure that everyone has permission to read and write as shown above, however and this is the bit that made it work for me.

under the sharing and permissions box there is a + - and a cog

Click the cog and then select "Apply to enclosed items" a warning box will pop stating are you sure

click yes and hey presto you should be able to open those pesky files.

I tried to post images of the boxes but as this is my 1st post I couldn't

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.