Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've searched for days and tried a bazillion methods already. I fear I may have to fiddle with the Registry. Here's the problem...

Everything worked fine at home. I went to Florida and used their free wifi at the hotel. Got back home and now my laptop will not connect automatically, nor will it give me the autoconnect button. Again I would like to reiterate - I have tried a few dozen recommended fixes and they do not work. I need a hard core answer.

I have an IT associates degree and I have worked with the Registry before so I am not a novice. I am tired of having to reconnect each time I boot up or when I wake it from sleep. Please help. Thank you in advance.

----edited my question to add the following: I have tried the suggestions listed at these links...

community.spiceworks.com/topic/200950-windows-7-machine-will-not-automatically-connect-to-wireless

answers.microsoft.com/en-us/windows/forum/windows_7-networking/wireless-network-will-not-connect-automatically-on/4b34d624-81f6-4972-a34a-a74fd1825dd8

www.tomshardware.com/forum/31865-63-auto-connect-wifi

----2nd edit to add the following:

I did try the restore point option. Thank you for your reply.

I have a Toshiba Satellite L505-S5971. Thank you for replying also.

share|improve this question
2  
If you want a "hard core answer" then tell us what you've tried or outline the exact order in which you do things to produce an exact result. –  user2714915 Sep 30 '13 at 10:40
    
I order to prevent getting suggestions that you've already tried, I would suggest listing them. We cannot magically know which methods you haven't tried yet. –  Moses Sep 30 '13 at 14:35
    
I have a few questions... Is this a corp laptop or personal? If corp, check out group policy settings. Was the hotels wifi ssid something generic like attwifi, linksys, etc? Does the laptop auto connect to any networks at all, or just doesn't with yours? –  Colyn1337 Oct 12 '13 at 22:09

2 Answers 2

I expect that you are using a Dell or a HP machine running win-7. Dell and HP(among others) laptops have their specific Wireless connectivity applications.

When you connect to a wireless network, you should be receiving a small window at the bottom Right hand corner of your screen.

Click on that screen to open that utility.

Now, remove the profile of the Florida's Hotel.

Ensure that your connect automatically option is checked for your home network.

Now, Open Control Panel >> Network And Sharing Center >> Manage wireless networks.

Remove the Florida's Hotel's Profile.

Open the properties of your home network.

Click on Connect Automatically

Now You should be able to connect to your home network automatically. If not then, remove your home network from both the location and connect to your home network. It'll start working fine.

share|improve this answer

Did you update any drivers recently? A wifi driver update once caused my win7 to take forever to reconnect; reverting to the older version made it perfectly fine again. (BTW I have a thinkpad t400 w/ intel 5100 wireless).

Try system restore to a point before when you connected to the hotel wifi.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.