Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Yesterday, I tried to remove Windows 8 and installed Linux Mint. It was ok untill I restarted.

My hardware: Dell Vostro 3560 Windows 8 Pre-Installed SSD 32 GB (mSata)

The problem is that after the reinstall, I could not find my grub. Every search I perform @Google returns a lot of people choosing dual boot, but I am not dual booting. I removed Windows 8 because I just want Linux Mint running on my hardware.

When I restart, I am getting this error:

Failed to open /EFI/Microsoft/Boot/grubx64.efi failed to load grub Failed to open /EFI/Boot/grubx64.efi failed to load grub

I think my system is installed and working fine, but how can I boot Linux Mint without a bootloader working fine?

Some people told me about reFind, but I am afraid to mess something.

EDIT: I am being downvoted. I don't know why. Can somebody explain? I think my question is well formatted and there is no question like mine here (I did a extensive search before asking). If you are going to downvote, let me know what information my question is missing.

share|improve this question
2  
What are you going to mess up? Your system is unbootable, you have never logged into Mint, so you have nothing to lose. –  Ramhound Sep 30 '13 at 12:59
    
Good. Thanks for your response. But do you have any tips for what I should to do to fix it? –  Mauricio Abreu Sep 30 '13 at 13:11
1  
Start by installing reFind –  Ramhound Sep 30 '13 at 13:15
    
Can you explain what happened? I read some docs about UEFI, boot loader, grub and I could not find a reason why it is happening and how reFind would help me. I am trying understanding to help others to fix this problem. –  Mauricio Abreu Sep 30 '13 at 13:35
1  
Secure Boot is not going to work with Linux unless very specific steps are taken, at your skill level, those steps are best left till a future time. Sounds like you have not done a complete format and your original EFI partition information still exists. –  Ramhound Sep 30 '13 at 13:53
show 2 more comments

2 Answers

up vote 1 down vote accepted

Chances are you removed the Windows partition but did not remove the Windows boot loader from the EFI System Partition (ESP). That, possibly in conjunction with some weirdness in the Linux installation or an EFI bug, has caused the computer to ignore the Linux boot loader on the ESP.

Using rEFInd may help because it's an alternative boot manager. If you prepare the USB flash drive or CD-R version of rEFInd, you should be able to boot to it much as you booted to a Linux installer. rEFInd should then detect your OSes, including your Linux kernel(s). If you installed Mint with the default options, rEFInd will let you boot into Mint. At that point, installing the Debian package version of rEFInd will put it on your hard disk and you won't need the CD-R or USB flash drive any more.

That said, there are things that can go wrong with this procedure, mainly because of EFI bugs. If you have problems, post back with details to get more help. There are other ways to fix this, too; I'm emphasizing rEFInd simply because you've already mentioned it. (Disclaimer: I am rEFInd's maintainer.)

share|improve this answer
add comment

I did the same thing and Win 8 would not boot from the GRUB menu. I was trying different keys and found that when I hit F12 during bios boot sequence that a bios menu came up with boot option (not the standard F1 F2 type menu where you change settings, this listed just the items that were bootable) and when I selected the Win 8 listing it booted into Win 8 just fine. When I tried to boot from the GRUB nothing would happen, just a black screen. Try various F keys and see if you have the same iption. I am using a Lenovo all in one (no touch screen).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.