Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I hate when my PC gives me feedback with sounds, so the first thing I do after I install windows is disable all of them. Recently, I upgraded to Windows 8 and I can't find the option to disable the unlock sound.

I have all sounds disabled (including logon and logoff sounds), but this particular sound isn't in the list.

I tried deleting the file and it told me that I require permission from trusted installer. Then I rebooted into my other windows partition and tried again. I got the same message, even after taking ownership of the folder.

Finally I tried changing the location of the sound to point to an empty wav via regedit (in HKEY_CURRENT_USER\AppEvents\Schemes\Apps.Default\WindowsUnlock). Again, nothing happened.

How can I get rid of this annoyance for good?

share|improve this question
    
askvg.com/… –  Ƭᴇcʜιᴇ007 Sep 30 '13 at 15:20
    
thanks! I had seen that article but didn't read it fully... I thought it just talked about the cpl items. Why Microsoft would do such a thing is beyond me though. BTW you should post that as an answer so I can mark the question as solved –  Nicolás Straub Valdivieso Sep 30 '13 at 15:48

1 Answer 1

up vote 6 down vote accepted

Microsoft has removed options to change or disable Windows logon, logoff, exit and unlock event sounds from Windows 8 sound settings present in Control Panel. These steps will help you in bringing those sound options back in Windows 8.

  1. Press WIN+R key combination to launch RUN dialog box then type regedit and press Enter. It'll open the Registry Editor.

  2. Now go to following key: HKEY_CURRENT_USER\AppEvents\EventLabels

  3. Under this key, you'll find several sub-keys which are actually associated with all the sound options which are shown in Sound applet present in Control Panel.

    Now scroll down a little and you'll find "WindowsLogon" key. Click on the key and in right-side pane, you'll notice the DWORD ExcludeFromCPL which would be set to 1.

  4. Double-click on the DWORD and change its value to 0 or simply delete the DWORD.

  5. Do the same for other keys as well such as WindowsLogoff, WindowsUnlock and SystemExit.

  6. Close Registry Editor and open Sound applet from Control Panel and you'll get the options to customize Windows logon, logoff, exit and unlock sounds back.

Source/More Info

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.