Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed Linux Mint 15 on my machine where Windows 8 was pre-installed. After successfully doing so, the grub menu would not show when I would boot the computer. It would boot straight into windows. After hours of researching, I followed the procedure here: and tried to install the grub through my Live CD for Mint 15. It gave me no problems when I followed the instructions but after restarting my computer, the grub still did not show? I am quite new to this, so excuse me if I am missing something obvious!

share|improve this question

have you disabled secure boot in bios? now windows 8 pre-installed comes with secure boot enabled by-default which doesn't allow any unsigned code to execute during boot process. Try disabling secure boot in bios and run boot-repair utility after that.

share|improve this answer

Sorry in case of dual boot for windows 8 we can't make the grub entry for second O.S. But still if you want to use the same then you need to go through any third party tool like Oracle virtual box or Vmware etc

share|improve this answer
up vote 0 down vote accepted

Thanks for trying to help me out guys, but I fixed it and installed GRUB onto my Windows 8 computer. I already had Linux installed, so all I did was boot my PC with the Live CD for Linux Mint and use Boot Repair. I used the normal recommended settings and it reinstalled Grub2 for me. For anyone with the same issue in the near future, I completed the steps from the link I provided in the question before using Boot Repair, so to be safe, you should try the same.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.